您的位置:首页 > 其它

[2011山东ACM省赛] Mathman Bank(模拟题)

2014-04-20 17:30 459 查看


Mathman Bank



Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^


题目描述

With the development of mathmen's mathematics knowlege, they have finally invented
computers. Therefore, they want to use computers to manage their banks. However, mathmen's programming skills are not as good as their math-
ematical skills. So they need your help to write a bank management system software.

The
system must support the following operations:

1.
Open account: given the customer's name and password, and an initial deposit,
open an bank account for the customer.

2.
Deposit: given the amount of money and the name of the customer, deposit
money in the customer's account.

3.
Withdraw: given the amount of money, the customer's name and password,
withdraw money from the customer's account.

4.
Transfer: given the amount of money, sender's name, sender's password and
receiver's name, transfer money from the sender's account to the

receiver's
account.

5.
Check: given the customer's name and password, print the balance of the
customer's account.

6.
Change password: given the customer's name and old password, and the
new password, replace the customer's old password with the new one.

Initially,
no account exists in the bank management system .

输入

The first line of the input contains one positive integer, n (n <= 1000), which is
the number of commands. Each of the following n lines contains one of the following commands, in the
following format:

1.
O "customer" "password" "initial deposit" - open an account for "customer",
set the password to "password" and deposit "inital deposit" money
in the account. "customer" and "password" are strings, and "initial
deposit" is an integer.

2.
D "customer" "amount" - deposit "amount" money in "customer"'sac-
count. "customer" is a string, and "amount" is an integer.

3.
W"customer" "password" "amount" - withdraw "amount" money from "customer"'s
account. "customer" and "password" are strings, and amount

4.
T "sender" "password" "receiver" "amount" - transfer "amount" money from
"sender"'s acount to "receiver"'s account. "sender", "pasword" and
"receiver" are strings, and "amount" is an integer.

5.
C "customer" "password" - check "customer"'s balance. "customer" and
"password" are strings.

6.
X "customer" "old password" "new password" - replace "customer"'s old
password with "new password". "customer", "old password" and "new
password" are strings.

All
of the strings appearing in the input consist of only alphebetical letters and
digits, and has length at most 10. All the integers in the input are nonnegative,
and at most 1000000.

Refer
to the sample input for more details.

输出

For each of the commands, output one of the following results, respectively:

1.
Open account: If "customer" already has an account, output "Account
exists." (without quotation marks); otherwise, output "Successfully
opened an account." (without quotation marks).

2.
Deposite: If "customer" doesn't have an account ,output "Account does not
exist."; otherwise, output "Successfully deposited money."(without quotation
marks).

3.
Withdraw: If "customer" doesn't have an account, output "Account does
not exist."; otherwise, if "customer"'s password doesn't match "password",
output "Wrong password."; otherwise, if there are less money
than "amount" in "customer"'s account, output "Money not enough.";
otherwise, output "Successfully withdrew money." quotation marks).

4.
Transfer: If "sender"'s account or "receiver"'s account doesn't exist,
output "Account does not exist."; otherwise, if "sender"'s password
doesn't match "password", output "Wrong password."; otherwise,
if there is less money than 'amount" in "sender"'s account, output
"Money not enough."; otherwise, output "Successfully transfered money."

5.
Check: If "customer"'s account doesn't exist, output "Account does not
exist."; otherwise, if "customer"'s password doesn't match "password",
output "Wrong password."; otherwise, output the balance of "customer"'s
account.

6.
Change password: If "customer" doesn't have an account, output "Account
does not exist."; otherwise, if "customer"'s password doesn't match
"old password", output "Wrong password."; otherwise, output 'Successfully
changed password.".

示例输入

25
W Alice alice 10
O Alice alice 10
C Alice alice
D Bob 10000
O Bob bob 100
D Alice 50
C Alice alice
X Bob bob BOB
C Bob bob
O Bob bob 10
T Bob bob Alice 100000
W Alice alice 10
T Bob BOB Alice 100000
T Bob BOB Alice 100
C Alice alice
C Bob BOB
T Alice alice BOB 10
T ALICE alice Bob 10
X Jack jack JACE
X Alice ALICE alice
W Alice Alice 10
W Alice alice 200
T Alice alice Bob 80
C Alice alice
C Bob BOB


示例输出

Account does not exist.
Successfully opened an account.
10
Account does not exist.
Successfully opened an account.
Successfully deposited money.
60
Successfully changed password.
Wrong password.
Account exists.
Wrong password.
Successfully withdrew money.
Money not enough.
Successfully transfered money.
150
0
Account does not exist.
Account does not exist.
Account does not exist.
Wrong password.
Wrong password.
Money not enough.
Successfully transfered money.
70
80


提示

来源

山东省第二届ACM大学生程序设计竞赛

解题思路:

模拟银行开设账户,存款,取款,转账等业务,题目没难度,按照题意模拟,写代码时要仔细。



代码:

#include <iostream>
#include <string.h>
using namespace std;

struct Node//为每个账户开设一个结构体
{
string Name;//姓名
string Code;//密码
int Money;//存款金额
}node[1002];

int find(Node x[],int m,string name)//两个功能,判断name是否已经开了账户,如果已经开了返回在数组中的位置
{
for(int i=0;i<m;i++)
{
if(x[i].Name==name)
{
return i;
}
}
return -1;
}

int main()
{
int n;char cm;
int m=0;
cin>>n;
while(n--)
{
cin>>cm;
if(cm=='O')//开设账户
{
string name,code;
int money;
cin>>name>>code>>money;
if(find(node,m,name)==-1||m==0)//该姓名没有开账户
{

node[m].Name=name;
node[m].Code=code;
node[m].Money=money;
m++;
cout<<"Successfully opened an account."<<endl;
}
else
cout<<"Account exists."<<endl;
}
if(cm=='D')
{
string name;int money;
cin>>name>>money;
if(find(node,m,name)==-1)
cout<<"Account does not exist."<<endl;
else
{
node[find(node,m,name)].Money+=money;
cout<<"Successfully deposited money."<<endl;
}
}
if(cm=='W')
{
string name,code;int money;
cin>>name>>code>>money;
if(find(node,m,name)==-1)
{
cout<<"Account does not exist."<<endl;
}
else
{
if(node[find(node,m,name)].Code!=code)
{
cout<<"Wrong password."<<endl;
}
else if(node[find(node,m,name)].Money<money)
{
cout<<"Money not enough."<<endl;

}
else
{
node[find(node,m,name)].Money-=money;
cout<<"Successfully withdrew money."<<endl;
}
}

}
if(cm=='T')
{
string name1,code,name2;
int money;
cin>>name1>>code>>name2>>money;
if(find(node,m,name1)==-1||find(node,m,name2)==-1)
cout<<"Account does not exist."<<endl;
else if(node[find(node,m,name1)].Code!=code)
cout<<"Wrong password."<<endl;
else if(node[find(node,m,name1)].Money<money)
cout<<"Money not enough."<<endl;
else
{
node[find(node,m,name1)].Money-=money;
node[find(node,m,name2)].Money+=money;
cout<<"Successfully transfered money."<<endl;
}
}
if(cm=='C')
{
string name,code;
cin>>name>>code;
if(find(node,m,name)==-1)
{
cout<<"Account does not exist."<<endl;
}
else if(node[find(node,m,name)].Code!=code)
{
cout<<"Wrong password."<<endl;
}
else
{
cout<<node[find(node,m,name)].Money<<endl;
}
}
if(cm=='X')
{
string name,code1,code2;
cin>>name>>code1>>code2;
int len=find(node,m,name);
if(len==-1)
{
cout<<"Account does not exist."<<endl;
}
else if(node[len].Code!=code1)
{
cout<<"Wrong password."<<endl;
}
else
{
node[len].Code=code2;
cout<<"Successfully changed password."<<endl;
}
}

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: