您的位置:首页 > 其它

hdu 1851 A Simple Game(博弈)

2014-04-18 16:36 441 查看
Agrael likes play a simple game with his friend Animal during the classes. In this Game there are n piles of stones numbered from 1 to n, the 1st pile has M1 stones, the 2nd pile has M2 stones, ... and the n-th pile contain Mn stones. Agrael and Animal take turns to move and in each move each of the players can take at most L1stones from the 1st pile or take at most L2 stones from the 2nd pile or ... or take Ln stones from the n-th pile. The player who takes the last stone wins.

After Agrael and Animal have played the game for months, the teacher finally got angry and decided to punish them. But when he knows the rule of the game, he is so interested in this game that he asks Agrael to play the game with him and if Agrael wins, he won't be punished, can Agrael win the game if the teacher and Agrael both take the best move in their turn?

The teacher always moves first(-_-), and in each turn a player must takes at least 1 stones and they can't take stones from more than one piles.

[align=left]Input[/align]
The first line contains the number of test cases. Each test cases begin with the number n (n ≤ 10), represent there are n piles. Then there are n lines follows, the i-th line contains two numbers Mi and Li (20 ≥ Mi > 0, 20 ≥ Li > 0).

[align=left]Output[/align]
Your program output one line per case, if Agrael can win the game print "Yes", else print "No".

[align=left]Sample Input[/align]

2

1
5 4
2

1 1

2 2

[align=left]Sample Output[/align]

Yes

No
========================================================================================================
经典的巴什博弈,只不过,这题又有些不同,有N堆的石子,以及每堆都有不同的取数限制,仍然可以用经典的方法,实在惊讶!
看代码:

#include <stdio.h>
#include <string.h>

int main()
{
int n,m,i,j,k,t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&k);
int res=0;
for(i=0;i<k;i++)
{
scanf("%d%d",&n,&m);
res^=(n%(m+1));
}
if(res==0)printf("Yes\n");
else printf("No\n");
}
return 0;
}


  博弈简短的代码,能解决复杂的问题,实在略吊!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: