您的位置:首页 > 其它

Friends zoj 3710

2014-04-17 15:33 302 查看
Friends
Time Limit:
2 Seconds      Memory Limit: 65536 KB

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than
k friends in common, they will become friends in several days. Currently, there are totally
n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer
T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers
n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤
k ≤ n, there will be no duplicated friendship) followed by
m lines showing the current friendship. The ith friendship contains two integers
ui, vi (0 ≤ ui, vi <
n, ui ≠ vi) indicating there is friendship between person
ui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0


Sample Output

2
0
4


Author: ZHUANG, Junyuan

Contest: The 10th Zhejiang Provincial Collegiate Programming Contest

一开始以为是这个题目是这个题目是个并查集,后来想想其实不是啊,后来以为是图论题目,但是想想其实也不是这样,因为不会不重复搜,后来看看这个题目时间给了2s,

但是数最大才是100,证明就是暴搜啊,暴搜可以想,但是不断有新的边产生,那又该怎么办呢,所以外面应该放一个while(1),当我们没法产生新的变时,证明搜索可以暴搜

结束了。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
int i,j,t,q;
int T,n,m,k;
scanf("%d",&T);
int map[150][150];
while(T--)
{

scanf("%d%d%d",&n,&m,&k);
memset(map,0,sizeof(map));
int a,b;
for(i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
map[a][b]=map[b][a]=1;
}
int s1=0;
int s2=0;
int s3=0;
int s4=0;
while(1)
{
s1=0;
for(i=0;i<n;i++)
{

for(j=i+1;j<n;j++)
{

if(map[i][j]==0)
{

//printf("i %d j %d\n",i,j);
s2=0;

for(t=0;t<n;t++)
{
if(map[i][t]&&map[t][j])
{
s2++;
}

}
//printf("s1 %d\n",s1);
if(s2>=k)
{
s1++;//标记用的
s4++;
map[i][j]=map[j][i]=1;
//break;
}

}

}

}

if(s1==0)
break;

}
printf("%d\n",s4);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  博客 搜索 sizeof zoj less