您的位置:首页 > 其它

HDU 1074Doing Homework(状态压缩dp)

2014-04-15 19:10 316 查看
这道题目开了好长时间了啊,后来一直忘记了做,今天做了一道状压的题目突然想到了这道题目。注意可以从后向前枚举这样可以保证最小的在最后面了啊。


Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4744    Accepted Submission(s): 1944


Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject),
C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

 

Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

 

Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

 

Sample Output

2
Computer
Math
English
3
Computer
English
Math

#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-8
#define M 1000100
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898

using namespace std;

const int maxn = 50010;

struct node
{
int day;
int score;
int pre;
int num;
} dp[maxn];

struct node1
{
int End;
int cost;
char name[120];
} f[50];
int main()
{
int T;
cin >>T;
while(T--)
{
int n;
cin >>n;
for(int i = 0; i < n; i++)
cin >>f[i].name>>f[i].End>>f[i].cost;
dp[0].day = 0;
dp[0].score = 0;
for(int i = 1; i < (1<<n); i++)
{
dp[i].score = INF;
for(int j = n-1; j >= 0; j--)
{
int x = 1<<j;
if(i&x)
{
int t = i-x;
int sum = dp[t].day+f[j].cost-f[j].End;
if(sum < 0)
sum = 0;
if(dp[i].score > dp[t].score+sum)
{
dp[i].score = dp[t].score+sum;
dp[i].day = dp[t].day+f[j].cost;
dp[i].num = j;
dp[i].pre = t;
}
}
}
}
cout<<dp[(1<<n)-1].score<<endl;
int p = (1<<n)-1;
int num[50];
int t = 0;
while(p)
{
num[t++] = dp[p].num;
p = dp[p].pre;
}
for(int i = t-1; i >= 0; i--)
cout<<f[num[i]].name<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: