您的位置:首页 > 其它

杭电 1004 Let the Balloon Rise

2014-04-15 17:29 621 查看

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s):    Accepted Submission(s):


[align=left]Problem Description[/align]
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color
and find the result.

This year, they decide to leave this lovely job to you.

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case
letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 

[align=left]Output[/align]
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

 

[align=left]Sample Input[/align]

5
green
red
blue
red
red
3
pink
orange
pink
0

 

[align=left]Sample Output[/align]

red
pink

AC代码如下:

#include<stdio.h>
#include<string.h>
int main()
{
int s[1001];
char a[1001][16],b[1001][16];
int T,max,i,c,j;
while(~scanf("%d",&T)&&T)
{
memset(s,0,sizeof(s));
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
for(i=0;i<T;i++)
scanf("%s",&a[i]);
strcpy(b[0],a[0]);
for(i=0,c=0;i<T;i++)
{
for(j=0;j<=c;j++)
if(strcmp(a[i],b[j])==0)
break;
if(j==c+1)
{
strcpy(b[c+1],a[i]);
c++;
}
}
for(i=0;i<=c;i++)
{
for(j=0;j<T;j++)
{
if(strcmp(b[i],a[j])==0)
s[i]++;
}
}
/*for(i=0;i<=c;i++)
puts(b[i]);*/
max=0;
for(i=0;i<=c;i++)
if(s[i]>max)
max=s[i];
for(i=0;i<=c;i++)
if(s[i]==max)
{
break;
}
printf("%s\n",b[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 acm