您的位置:首页 > 其它

NYOJ 220 推桌子

2014-04-14 20:23 288 查看
描述

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

输入

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables
to move. 

Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 

line, the remaining test cases are listed in the same manner as above.

输出

The output should contain the minimum time in minutes to complete the moving, one per line.

样例输入

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50


样例输出

10
20
30


 

s ->t 但s并不一定比t小。

注意房间号到走廊号的转换 :房间号/2+房间号%2;方法不一。

计算出所有走廊所用到的的次数。找出最大的即可。

 

#include <stdio.h>
#include <string.h>
typedef struct
{
int s;              //the table is move s to t;
int t;
} room;

int main()
{

void thtime(room rm[200],int n);
int i;
int t;
int n;
int tem;
room rm[200];
scanf("%d",&t);
while(t--)                  //the cases
{
scanf("%d",&n);

for(i=0;i<n;i++)
{
scanf("%d%d",&rm[i].s,&rm[i].t);    //从s到t,不一定s<t.
if(rm[i].s>rm[i].t)
{
tem=rm[i].t;
rm[i].t=rm[i].s;
rm[i].s=tem;
}

}

thtime(rm,n);

}

return 0;

}
void thtime(room rm[200],int n)
{
int i,j;
int move[201];
int rel;
memset(move,0,sizeof(move));
for (i=0;i<n;i++)
{
rm[i].s=rm[i].s/2+rm[i].s%2;
rm[i].t=rm[i].t/2+rm[i].t%2;

}

for (i=0;i<n;i++)
{
for(j=rm[i].s;j<=rm[i].t;j++)
move[j]++;

}
rel=move[0];
for (i=0;i<201;i++)
if(move[i]>rel)
rel=move[i];

printf("%d\n",rel*10);

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM