您的位置:首页 > 其它

POJ 3009 Curling 2.0

2014-04-14 18:33 253 查看
链接:http://poj.org/problem?id=3009

题目:

Curling 2.0

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10334Accepted: 4352
Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game
is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed
until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.



Fig. 1: Example of board (S: start, G: goal)
The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:

The stone hits a block (Fig. 2(b), (c)).

The stone stops at the square next to the block it hit.
The block disappears.

The stone gets out of the board.

The game ends in failure.

The stone reaches the goal square.

The stone stops there and the game ends in success.

You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.



Fig. 2: Stone movements
Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).



Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board

First row of the board

...

h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position
The dataset for Fig. D-1 is as follows:

6 6

1 0 0 2 1 0

1 1 0 0 0 0

0 0 0 0 0 3

0 0 0 0 0 0

1 0 0 0 0 1

0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output
1
4
-1
4
10
-1


解题思路:

这是一个搜索的问题,void dfs(int cur, int x, int y);cur表示走的步数,x表示行,y表示列,从第x行,y列开始搜索。搜索的时候,共有4个方向,分4次,每次沿着一个方向,看看能不能走得通,如果可以的话,就沿着这个方向走,直到遇到障碍停下来,将障碍位置置为0,再从新的起点开始搜索,回溯的时候还原为1;用全局变量step来记录走的路径中最短的路的步数。

代码:

#include <iostream>
#include <cstdio>
#include <limits.h>
#include <cstring>
using namespace std;

#define min(x,y) x < y ? x : y
const int MAXN = 25;
int sx, sy, w, h, flag, step, map[MAXN][MAXN];

void dfs(int cur, int x, int y)
{
	if(cur > 10) return;
	if(x < 0 || x >= h || y < 0 || y >= w) return;
	for(int i = x - 1; i >= 0; i--)
	{
		if(3 == map[i][y])
		{
			flag = 1;
			step = min(step, cur);
			return;
		}
		if(1 == map[i][y])
		{
			if(i == x - 1) break;
			map[i][y] = 0;
			dfs(cur + 1, i + 1, y);
			map[i][y] = 1;
			break;
		}
	}
	for(int i = x + 1; i < h; i++)
	{
		if(3 == map[i][y])
		{
			flag = 1;
			step = min(step, cur);
			return;
		}
		if(1 == map[i][y])
		{
			if(i == x + 1) break;
			map[i][y] = 0;
			dfs(cur + 1, i - 1, y);
			map[i][y] = 1;
			break;
		}
	}
	for(int i = y - 1; i >= 0; i--)
	{
		if(3 == map[x][i])
		{
			flag = 1;
			step = min(step, cur);
			return;
		}
		if(1 == map[x][i])
		{
			if(i == y - 1) break;
			map[x][i] = 0;
			dfs(cur + 1, x, i + 1);
			map[x][i] = 1;
			break;
		}
	}
	for(int i = y + 1; i < w; i++)
	{
		if(3 == map[x][i])
		{
			flag = 1;
			step = min(step, cur);
			return;
		}
		if(1 == map[x][i])
		{
			if(i == y + 1) break;
			map[x][i] = 0;
			dfs(cur + 1, x, i - 1);
			map[x][i] = 1;
			break;
		}
	}
}

int main()
{
	while(~scanf("%d%d", &w, &h) && (w || h))
	{
		memset(map, 0, sizeof(map));
		for(int i = 0; i < h; i++)
		{
			for(int j = 0; j < w; j++)
			{
				scanf("%d", &map[i][j]);
				if(2 == map[i][j])
				{
					sx = i;
					sy = j;
					map[i][j] = 0;
				}
			}
		}
		
		flag = 0; step = INT_MAX;
		dfs(1, sx, sy);
		if(0 == flag) step = -1;
		printf("%d\n", step);
	}
	
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: