您的位置:首页 > 其它

HDU 1142 A Walk Through the Forest (搜索-DFS)

2014-04-14 11:27 567 查看


A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5182 Accepted Submission(s): 1889



Problem Description

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A
nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.

The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from
B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.



Input

Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections
N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any
direction he chooses. There is at most one path between any pair of intersections.



Output

For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647



Sample Input

5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0




Sample Output

2
4




题目意思:寻找一共有多少条符合题意的路。能够从点A走到点B的要求是:点A到终点的最短路 > 点B到终点的最短路。先一遍迪杰斯特拉,然后一遍记忆化dfs搜索就可以了。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <map>
#include <vector>
#include <climits>

using namespace std;

const int MAX = 1002;

map<int,vector<int> > adj;
int road[MAX][MAX],dist[MAX],visit[MAX],cp[MAX],n,m,ans;

int dfs(int s){
	if(cp[s]!=0)return cp[s];
	if(s!=1 && dist[s]>=dist[1])return 0;

    vector<int>::iterator ite = adj[s].begin();
    for(;ite!=adj[s].end();++ite){
		if(dist[s]>dist[*ite]){
			cp[s] += dfs(*ite);
		}
    }
	return cp[s];
}

void DJ(){
	int i,j,k,mm;

	for(i=1;i<=n;++i){
		dist[i] = road[2][i];
	}

	visit[2] = 1;

	for(i=1;i<n;++i){
		mm = INT_MAX;
		k = 2;
		for(j=1;j<=n;++j){
			if(visit[j]==0 && dist[j]<mm){
				mm = dist[j];
				k = j;
			}
		}
		visit[k] = 1;

		for(j=1;j<=n;++j){
			if(visit[j]==0 && road[k][j]!=INT_MAX){
				if(dist[k] + road[k][j]<dist[j]){
					dist[j] = dist[k] + road[k][j];
				}
			}
		}
	}
}

void init(){
	int i,j;
	for(i=1;i<=n;++i){
		cp[i] = 0;
		visit[i] = 0;
		for(j=1;j<=n;++j){
			road[i][j] = INT_MAX;
		}
	}
}

int main(){
	//freopen("in.txt","r",stdin);
	int i,x,y,c;
	while(scanf("%d",&n)!=EOF && n){
		init();
		adj.clear();
		scanf("%d",&m);
		for(i=0;i<m;++i){
			scanf("%d %d %d",&x,&y,&c);
			adj[x].push_back(y);
			adj[y].push_back(x);
			road[x][y] = road[y][x] = c;
		}
		DJ();
		cp[2] = 1;
		dist[2] = 0;
		ans = dfs(1);
		printf("%d\n",ans);
	}
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: