您的位置:首页 > 产品设计 > UI/UE

递推—杭电1297 Children’s Queue

2014-04-14 10:40 351 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1297

Children’s Queue

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10127    Accepted Submission(s): 3232
[/b]

[align=left]Problem Description[/align]
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one
girl stands side by side. The case n=4 (n is the number of children) is like

FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM

Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

 
[align=left]Input[/align]
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 
[align=left]Output[/align]
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 
[align=left]Sample Input[/align]

1
2
3

 
[align=left]Sample Output[/align]

1
2
4

 

#include<iostream>
#include<string>
using namespace std;
string add(string s1,string s2)
{

int j,l,la,lb;
string max,min;
max=s1;
min=s2;
if(s1.length()<s2.length())
{
max=s2;
min=s1;
}//保证max是最长的一个数
la=max.size();
lb=min.size();
l=la-1;
for(j=lb-1;j>=0;j--,l--)
max[l] += min[j]-'0'; //使对应每位数相加
for(j=la-1;j>=1;j--)
if(max[j]>'9')//如果当前位数大于9,当前数减10,向前一位进1
{
max[j]-=10;
max[j-1]++;
}
if(max[0]>'9')
{
max[0]-=10;
max='1'+max;
}
return max;
}
int main(){
int n,i;
string a[1001];
a[0]="1";
a[1]="1";
a[2]="2";
a[3]="4";
for(i=4;i<1001;++i)
a[i]=add(add(a[i-1],a[i-2]),a[i-4]);//每两个数一调用大数相加模板
while(cin>>n)
cout<<a
<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: