您的位置:首页 > 其它

poj 1125 Stockbroker Grapevine——Floyd

2014-04-12 16:33 357 查看
Stockbroker Grapevine

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 25234 Accepted: 13939

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours
in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass
the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community.
This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are,
and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring
to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of
stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.

It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the
message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3

2 2 4 3 5

2 1 2 3 6

2 1 2 2 2

5

3 4 4 2 8 5 3

1 5 8

4 1 6 4 10 2 7 5 2

0

2 2 5 1 5

0

Sample Output

3 2
3 10

================================================================================

题目大意:证券经理要会放假消息影响股市走向,每个证券经理有自己信任的证券经理,只有来自信任的人的消息才会继续往下传,信任关系是单向的。每次传消息都要花时间。

求以哪个证券经理为起点能最快地把假消息传遍所有证券经理,有可能最后有若干证券经理谁的消息都不信。

如果假消息传遍所有人,输出起点和传到所有人用的最短时间;如果传不到所有人,输出disjoint。

解题思路:将证券经理看做点,信任关系看做有向边,传消息花费的时间看做边权,则需要求正边权图的全局最短路。

遍历起点,若每个起点到各点的最长最短路记为dMax[ i ],则答案为所有< i , dMax[ i ] > 中dMax[ i ]最小的一对。若最小的一对dMax[ i ] == INF,则输出disjoint。//Memory: 388K Time: 0MS

#include<cstdio>

const int N = 101;
const int INF = 0x7fffffff;

int n, d

, g

;
//Floyd算法
void Floyd()
{
int i, j, k;
for( i = 1 ; i <= n ; i++ ) //初始化d数组
for( j = 1 ; j <= n ; j++ )
d[i][j] = g[i][j];
for( k = 1 ; k <= n ; k++ ) //Floyd核心
for( i = 1 ; i <= n ; i++ )
for( j = 1 ; j <= n ; j++ )
if( d[i][k] < INF && d[k][j] < INF && d[i][k]+d[k][j] < d[i][j] )
d[i][j] = d[i][k]+d[k][j];
}

int main()
{
while(scanf("%d", &n),n)
{
for( int i = 1 ; i <= n ; i++ ) //初始化邻接矩阵
for( int j = i+1 ; j <= n ; j++ )
g[i][j] = g[j][i] = INF;
for( int i = 1 ; i <= n ; i++ )
{
int num;
scanf("%d", &num);
while(num--)
{
int u, c;
scanf("%d%d", &u, &c);
g[i][u] = c; //填写邻接矩阵
}
}
Floyd();
int ansV, ansL = INF;
for( int i = 1 ; i <= n ; i++ ) //遍历起点
{
int l = 0;
for( int j = 1 ; j <= n ; j++ )
if( j != i && d[i][j] > l ) //找最长最短路
{
l = d[i][j];
if( l == INF )
break;
}
if( l < ansL ) //找最短的最长最短路并记录起点
{
ansV = i;
ansL = l;
}
}
if( ansL == INF )
printf("disjoint\n");
else
printf("%d %d\n", ansV, ansL);
}
return 0;
}Floyd是O(N^3)还0ms,数据是有多弱,大水题。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm poj Floyd