您的位置:首页 > 其它

NYOJ 309 BOBSLEDDING(dp)

2014-04-12 13:54 274 查看


BOBSLEDDING

时间限制:1000 ms | 内存限制:65535 KB
难度:3

描述

Dr.Kong has entered a bobsled competition because he hopes his hefty weight will give his an advantage over the L meter course (2 <= L<= 1000). Dr.Kong will push off the starting
line at 1 meter per second, but his speed can change while he rides along the course. Near the middle of every meter Bessie travels, he can change his speed either by using gravity to accelerate by one meter per second or by braking to stay at the same speed
or decrease his speed by one meter per second.

Naturally, Dr.Kong must negotiate N (1 <= N <= 500) turns on the way down the hill. Turn i is located T_i meters from the course start (1 <= T_i <= L-1), and he must be enter
the corner meter at a peed of at most S_i meters per second (1 <= S_i <= 1000). Dr.Kong can cross the finish line at any speed he likes.

Help Dr.Kong learn the fastest speed he can attain without exceeding the speed limits on the turns.

Consider this course with the meter markers as integers and the turn speed limits in brackets (e.g., '[3]'):

0 1 2 3 4 5 6 7[3] 8 9 10 11[1] 12 13[8] 14

(Start) |------------------------------------------------------------------------| (Finish)



Below is a chart of Dr.Kong 's speeds at the beginning of each meter length of the course:

Max: [3] [1] [8]

Mtrs: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14

Spd: 1 2 3 4 5 5 4 3 4 3 2 1 2 3 4

His maximum speed was 5 near the beginning of meter 4.

输入There are multi test cases,your program should be terminated by EOF

Line 1: Two space-separated integers: L and N

Lines 2..N+1: Line i+1 describes turn i with two space-separated integers: T_i and S_i
输出Line 1: A single integer, representing the maximum speed which Dr.Kong can attain between the start and the finish line, inclusive.
样例输入
14 3                                            
7 3
11 1
13 8


样例输出
5

题意:一个人在滑雪的过程中可以每秒加速1m/s,也可以保持速度不变,还可以每秒减速1m/s。滑道长L米,有n个拐角,当人滑行到拐角i时,他的速度不能超过Si。问在整个滑行过程中,人的最大速度是多少。
分析:假设人可以一直加速,从前往后遍历每个区间,当到某个拐角时的速度大于这个拐角的最大速度时,就向前更新前面的点的最大速度。dp[i]表示在第i米时可以滑行的最大速度。
#include<stdio.h>
#include<string.h>
int main()
{
    int L, n, i, dp[1005];
    while(~scanf("%d%d",&L,&n))
    {
        int a, b;
        memset(dp, 0, sizeof(dp));
        for(i = 0; i < n; i++)
        {
            scanf("%d%d",&a,&b);
            dp[a] = b;
        }
        int pos = 1, lim = 1;
        for(i = 0; i <= L; i++)
        {
            if(dp[i] == 0) //不是拐角的地方一直加速
                dp[i] = lim;
            else
            {
                if(dp[i] > dp[i-1])
                    dp[i] = dp[i-1] + 1;
                else
                {
                    pos = i; //从当前位置向前更新
                    while(dp[pos - 1] - dp[pos] > 1)
                    {
                        dp[pos-1] = dp[pos] + 1;
                        pos--;
                    }
                }
            }
            lim = dp[i] + 1;
        }
        int mmax = 0;
        for(i = 0; i <= L; i++)
            if(dp[i] > mmax)
                mmax = dp[i];
        printf("%d\n",mmax);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: