您的位置:首页 > 其它

类似区间计数的种类并查集两题--HDU 3038 & POJ 1733

2014-04-11 14:06 627 查看
1.POJ 1733

Parity game

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5744Accepted: 2233
Description
Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.
You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.
Input
The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).
Output
There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.
Sample Input
10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output
3

1.题目数据量较大,要用map来做哈希。

2.num[x]表示(fa[x],x]区间1的个数的奇偶性,0代表偶数,1代表奇数。以树根作为参照,每个点的num值即为树根到该点之间1的个数的奇偶性。

输入a,b

首先判断a,b是否在同一集合,如果在,则以其共同树根作为参照点,看异或值是否为0或1(0代表偶数,1代表奇数)。

如果不在,则合并两个集合,画一个图就知道了,图类似:http://www.cnblogs.com/whatbeg/p/3503585.html 中的图类似,假设fa[x] = y;

则 num[x] = num[a] ^ num[b] ^ k; (k = 0/1)



代码:





#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <map>
using namespace std;
#define N 10100

int fa
,num
;
map<int,int> mp;

void makeset(int n)
{
    for(int i=1;i<=10000;i++)
    {
        fa[i] = i;
        num[i] = 0;
    }
}

int findset(int x)
{
    if(x != fa[x])
    {
        int tmp = fa[x];
        fa[x] = findset(fa[x]);
        num[x] = num[x]^num[tmp];
    }
    return fa[x];
}

int unionset(int a,int b,char oe)
{
    int x = findset(a);
    int y = findset(b);
    int k = (oe == 'o'? 1:0);
    if(x == y)
    {
        if(num[a]^num[b] == k)
            return 1;
        else
            return 0;
    }
    else
    {
        fa[x] = y;
        num[x] = num[a]^num[b]^k;
        return 1;
    }
}

int main()
{
    int n,m,i,k,a,b,cnt;
    char ss[8];
    scanf("%d%d",&n,&m);
    makeset(n);
    k = 1;
    cnt = 0;
    for(i=1;i<=m;i++)
    {
        scanf("%d%d %s",&a,&b,ss);
        a = a-1;
        if(mp.find(a) == mp.end())
        {
            mp[a] = k++;
        }
        if(mp.find(b) == mp.end())
        {
            mp[b] = k++;
        }
        if(unionset(mp[a],mp[b],ss[0]))
            cnt++;
        else
            break;
    }
    printf("%d\n",cnt);
    return 0;
}


View Code




2.HDU 3038

题目大意:有n次询问,给出a到b区间的总和,问这n次给出的总和中有几次是和前面已近给出的是矛盾的,即命题为假的次数。

分析:与上面那题一样,用根节点作参照,每个点维护一个sum值,表示到根节点的距离,树根的距离为0。如果我们知道a到b之间的关系,a到c之间的关系,那么我们就可以知道a,b,c任意两个之间的关系。

输入a,b,判断是否属于同一集合,如果是,则判断 sum[b] - sum[a] 是否等于val。

如果不在同一集合,则合并,此时又画一个四点图可知, fa[y] = x; sum[y] = sum[b] - sum[a] + k; 不懂的话自己可以画一下。

然后就好搞了。



代码





#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define N 200100

int fa
,sum
;

void makeset(int n)
{
    for(int i=0;i<=n;i++)
    {
        fa[i] = i;
        sum[i] = 0;
    }
}

int findset(int x)
{
    if(x != fa[x])
    {
        int tmp = fa[x];
        fa[x] = findset(fa[x]);
        sum[x] = sum[x] + sum[tmp];
    }
    return fa[x];
}

int unionset(int a,int b,int k)
{
    int x = findset(a);
    int y = findset(b);
    if(x == y)
    {
        if(sum[b] - sum[a] == k)
            return 0;
        else
            return 1;
    }
    else
    {
        fa[y] = x;
        sum[y] = sum[a] - sum[b] + k;
        return 0;
    }
}

int main()
{
    int n,m,i,a,b,cnt,val;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        makeset(n);
        cnt = 0;
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&a,&b,&val);
            a = a-1;
            if(unionset(a,b,val))
            cnt++;
        }
        printf("%d\n",cnt);
    }
    return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: