您的位置:首页 > 其它

hdoj 1060 Leftmost Digit 幂指函数取对数

2014-04-11 13:52 232 查看

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12268 Accepted Submission(s): 4689



[align=left]Problem Description[/align]
Given a positive integer N, you should output the leftmost digit of N^N.

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

[align=left]Output[/align]
For each test case, you should output the leftmost digit of N^N.

[align=left]Sample Input[/align]

2
3
4


[align=left]Sample Output[/align]

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.


Descriptipn: 计算N^N结果的最左边的数

How to Do: 数学题 由sum=N^N,两边对10取对数,log10(sum)=Nlog10(N),有sum=10^(Nlog10(N));

由于10的整数次幂首位均为1,则仅需考虑Nlog10(N)的结果的小数部分即可

易错点: 1、数值太大,类型需要用long long.

2、对数函数的调用。

代码:

#include <iostream>

#include <stdio.h>

#include <math.h>

using namespace std;

int main()

{

long long t,n;

long long x,m;

double m1;

cin>>t;

while(t--)

{

cin>>n;

m1=n*log10(double(n));

x=(long long)(m1);

m1-=x;

m=(long long)(pow(10.0,m1));

cout<<m<<endl;

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: