您的位置:首页 > 其它

HDU 1059 Dividing 多重背包

2014-04-11 12:45 387 查看

Dividing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15260 Accepted Submission(s): 4238


[align=left]Problem Description[/align]
Marsha
and Bill own a collection of marbles. They want to split the collection
among themselves so that both receive an equal share of the marbles.
This would be easy if all the marbles had the same value, because then
they could just split the collection in half. But unfortunately, some of
the marbles are larger, or more beautiful than others. So, Marsha and
Bill start by assigning a value, a natural number between one and six,
to each marble. Now they want to divide the marbles so that each of them
gets the same total value.
Unfortunately, they realize that it
might be impossible to divide the marbles in this way (even if the total
value of all marbles is even). For example, if there are one marble of
value 1, one of value 3 and two of value 4, then they cannot be split
into sets of equal value. So, they ask you to write a program that
checks whether there is a fair partition of the marbles.

[align=left]Input[/align]
Each
line in the input describes one collection of marbles to be divided.
The lines consist of six non-negative integers n1, n2, ..., n6, where ni
is the number of marbles of value i. So, the example from above would
be described by the input-line ``1 0 1 2 0 0''. The maximum total number
of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

[align=left]Output[/align]
For
each colletcion, output ``Collection #k:'', where k is the number of
the test case, and then either ``Can be divided.'' or ``Can't be
divided.''.

Output a blank line after each test case.

[align=left]Sample Input[/align]

1 0 1 2 0 0

1 0 0 0 1 1

0 0 0 0 0 0

[align=left]Sample Output[/align]

Collection #1:
Can't be divided.
Collection #2:
Can be divided.
讲解:类似于 HDU 2844 里面有讲解;
AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[420010];
int main()
{
int a[6],b[6],k=1;
for(int i=0; i<6; i++)
{
a[i]=i+1;
}
while(k)
{
memset(dp,0,sizeof(dp));
int sum=0;
for(int j=0; j<6 ; j++)
{
cin>>b[j];
sum=sum+a[j]*b[j];
}
if(sum==0) break;
if(sum%2==1)
{
cout<<"Collection #"<<k<<":"<<endl<<"Can't be divided."<<endl<<endl;
}
else
{sum=sum/2;int ans=-100;
for(int i=0; i<6; i++)
{
if(a[i]*b[i]>=sum)
for(int j=a[i]; j<=sum ;j++)
{dp[j]=max(dp[j],dp[j-a[i]]+a[i]); if(dp[j]>ans) ans = dp[j];}
else {

for(int kk=1;kk<b[i] ; kk=kk*2)
{
for(int j=sum ; j>=a[i]*kk ; j--)
{
dp[j]=max(dp[j],dp[j-a[i]*kk]+a[i]*kk);
if(dp[j]>ans) ans=dp[j];
}
b[i]-=kk;
}
if(b[i]>0)
for(int j=sum ; j>=a[i]*b[i] ; j--)
{ dp[j]=max(dp[j],dp[j-a[i]*b[i]]+a[i]*b[i]);if(dp[j]>ans) ans=dp[j];}
}
}
if(ans == sum)
cout<<"Collection #"<<k<<":"<<endl<<"Can be divided."<<endl<<endl;
else cout<<"Collection #"<<k<<":"<<endl<<"Can't be divided."<<endl<<endl;
}
k++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: