您的位置:首页 > 其它

Function Run Fun

2014-04-10 20:45 288 查看
总时间限制: 1000ms 内存限制: 65536kB

描述
We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:

1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:

w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:

w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:

w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

输入
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
输出
Print the value for w(a,b,c) for each triple.
样例输入
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1


样例输出
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1


代码如下:

#include<iostream>
using namespace std;
int map[30][30][30];
int imap()
{
	int a,b,c;
	for(a=0;a<=20;a++)
		for(b=0;b<=20;b++)
			for(c=0;c<=20;c++)
			{
				if(a<=0||b<=0||c<=0)
				{
					 map[a][b][c]=1;
				}
				else if(a < b && b < c)
					map[a][b][c]=map[a][b][c-1] + map[a][b-1][c-1] - map[a][b-1][c];
				else
					map[a][b][c]=map[a-1][b][c] + map[a-1][b-1][c] + map[a-1][b][c-1] - map[a-1][b-1][c-1];
			}
   return 0;
}
int main()
{
	int a,b,c;
	imap();
	while(cin>>a>>b>>c)
	{
		if(a==-1&&b==-1&&c==-1)
		return 0;
		cout<<"w("<<a<<", "<<b<<", "<<c<<") = ";
		if(a<=0||b<=0||c<=0)
			cout<<1<<endl;
		else if(a>20||b>20||c>20)
			cout<<map[20][20][20]<<endl;
		else if(a < b && b < c)
			cout<<map[a][b][c]<<endl;
	    else
			cout<<map[a][b][c]<<endl;
	}
 return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: