您的位置:首页 > 其它

POJ 1852 Ants 模拟

2014-04-09 20:23 441 查看
Ants

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 8386Accepted: 3822
Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know
the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers
giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such
time.

Sample Input
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output
4 8
38 207

Source

Waterloo local 2004.09.19
话说当时在蓝桥杯初赛的时候,看到那个蚂蚁的题目时,想到了这道题,可是当时也没做过这道题 T_T

要是能搞懂,蚂蚁碰面转身和直接通过是等价的(蚂蚁没有区别)就很好写了。

#include <iostream>
using namespace std;
int main()
{
int l,m,n,a,max,min;
ios::sync_with_stdio(false);
cin>>n;
while (n--){
cin>>l>>m;
max=min=0;
while (m--){
cin>>a;
a=a>l-a?a:l-a;
max=max<a?a:max;
min=min<l-a?l-a:min;
}
cout<<min<<' '<<max<<endl;
}
return 0;
}


kdwycz的网站: http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: