您的位置:首页 > 其它

ZOJ 3769 Diablo III

2014-04-09 14:10 204 查看
描述

Diablo III is an action role-playing video game. A few days ago, Reaper of Souls (ROS), the new expansion of Diablo III, has been released! On hearing the news, the crazy video game nerd Yuzhi shouted: "I'm so excited! I'm so excited! I wanna kill the Diablo once more!"

The ROS introduced a lot of new features and changes. For example, there are two new attributes for players in the game: Damage and Toughness. The attribute Damage indicates the amount of damage per second you can deal and the Toughness is the total amount of raw damage you can take.

To beat the Diablo, Yuzhi need to select the most suitable equipments for himself. A player can carry at most 13 equipments in 13 slots: Head, Shoulder, Neck, Torso, Hand, Wrist, Waist, Legs, Feet, Shield, Weapon and 2 Fingers. By the way, there is a special type of equipment: Two-Handed. A Two-Handed equipment will occupy both Weapon and Shield slots.

Each equipment has different properties on Damage and Toughness, such as a glove labeled "30 20" means that it can increase 30 Damage and 20 Toughness for the player who equips it in the Hand slot. The total Damage and Toughness is the sum of Damage and Toughness of all equipments on the body. A player without any equipments has 0 Damage and 0 Toughness.

Yuzhi has N equipments stored in his stash. To fight against the Diablo without lose the battle, he must have at least M Toughness. In addition, he want to finish the battle as soon as possible. That means the Damage should be as much as possible. Please help Yuzhi to determine which equipments he should take.

输入

There are multiple test cases. The first line of input is an integer T indicates the number of test cases. For each test case:

The first line contains 2 integers N (1 <= N <= 300) and M (0 <= M <= 50000). The next N lines are the description of equipments. The i-th line contains a string Si and two integers Di and Ti (1 <= Di, Ti <= 50000). Si is the type of equipment in {"Head", "Shoulder", "Neck", "Torso", "Hand", "Wrist", "Waist", "Legs", "Feet", "Finger", "Shield", "Weapon", "Two-Handed"}. Di and Ti are the Damage and Toughness of this equipment.

输出

For each test case, output the maximum Damage that Yuzhi can get, or -1 if he can not reach the required Toughness.

样例输入

2
1 25
Hand 30 20
5 25
Weapon 15 5
Shield 5 15
Two-Handed 25 5
Finger 5 10
Finger 5 10

样例输出

-1
35


#include <stdio.h>
#include <string>
#include <map>
#include <vector>
#include <iostream>
#define MAXN 310
using namespace std;

int n,m;
map< string , int > M;

int max(int a, int b){
if(a>b)return a;
else return b;
}

void init(){
M["Head"]=0;
M["Shoulder"]=1;
M["Neck"]=2;
M["Torso"]=3;
M["Hand"]=4;
M["Wrist"]=5;
M["Waist"]=6;
M["Legs"]=7;
M["Feet"]=8;
M["Shield"]=9;//finger
M["Weapon"]=10;
M["Finger"]=11;
M["Two-Handed"]=12;
}

struct Node
{
int d,t;
}nod;

vector<Node> V[13];//存储同类物品
int dp[13][50001];
int vd,vt;

void read(){
int i,j,d,t;
char ch[30];
scanf("%d %d" ,&n ,&m);
for(i=0; i<13; i++){
V[i].clear();
}
for(i=0; i<n; i++){
scanf("%s %d %d" ,ch , &d ,&t);
int index=M[string(ch)];
nod.d=d;
nod.t=t;
V[index].push_back( nod );
if(index==9 || index==10){
V[12].push_back( nod );
}
}
//两只手的装备
for(i=0; i<V[9].size(); i++){
for(j=0; j<V[10].size(); j++){
nod.d=V[9][i].d+V[10][j].d;
nod.t=V[9][i].t+V[10][j].t;
V[12].push_back( nod );
}
}
//存戒指
V[9].clear();
for(i=0; i<V[11].size(); i++){
V[9].push_back( V[11][i] );
for(j=i+1; j<V[11].size(); j++){
nod.d=V[11][i].d+V[11][j].d;
nod.t=V[11][i].t+V[11][j].t;
V[9].push_back( nod );
}
}
V[11].clear();
}

int main(){
init();
int t;
int i,j,k;
scanf("%d" ,&t);
while( t-- ){
read();
memset(dp,-1,sizeof(dp));
//12单独处理一下,存到9
dp[10][0]=0;
for(i=0; i<V[12].size(); i++){
nod=V[12][i];
if(nod.t>m){
vt=m;
}else{
vt=nod.t;
}
vd=nod.d;
dp[10][vt]=max( dp[10][vt] , vd );
}
for(k=9; k>=0; k--){
for(j=0; j<=m; j++){
dp[k][j]=max( dp[k][j],dp[k+1][j] );
if( dp[k+1][j]==-1 )continue;
/*
dp[k][j] 表示k件装备,它所用的防御是j的伤害
当前装备伤害+之前伤害最大值
dp[k][vt]=max( dp[k][vt], nod.d+dp[k+1][j] )
*/
for(i=0; i<V[k].size(); i++){
nod=V[k][i];
if( nod.t +j > m ){
vt=m;
}else{
vt=nod.t +j;
}
dp[k][vt]=max( dp[k][vt], nod.d+dp[k+1][j] );
}
}
}
printf("%d\n" ,dp[0][m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: