您的位置:首页 > 其它

POJ训练计划2488_A Knight's Journey(DFS+回溯)

2014-04-09 01:21 549 查看
A Knight's Journey
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d
& %I64u

Description


Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 

If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3


Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4


解题报告
题目要你求出一条可以遍历整个棋盘,且是一条路到底,,,又要按字典顺序输出路径。。。
回溯思想不太会。。。
大概就是走到一条不能成功遍历棋盘的路上,倒回去往别的路上走,由于标记了已经走过的路,就要清除标记。。。
字典顺序图



#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <stdlib.h>
#define N
#define inf 99999999

using namespace std;
int n,m,cnt;
int vis[30][30];
struct node
{
int x, y;
}prim[1000];
int dx[]= {-1,1,-2,2,-2,2,-1,1};//字典
int dy[]= {-2,-2,-1,-1,1,1,2,2};
int dfs(int e,int s,int cnt)
{
if(cnt==n*m)
return 1;
for(int i=0; i<8; i++)
{
int x=e+dx[i];
int y=s+dy[i];
if(x>=1&&x<=m&&y>=1&&y<=n&&!vis[x][y])
{
vis[x][y]=1;
if(dfs(x,y,cnt+1))
{
prim[cnt].y=y;
prim[cnt].x=x;
return 1;
}
vis[x][y]=0;
}
}
return 0;
}
int main()
{
int t,i,j,k=1;
scanf("%d",&t);
while(t--)
{
memset(vis,0,sizeof(vis));
cnt=0;
scanf("%d%d",&m,&n);
vis[1][1]=1;
prim[0].x=1;
prim[0].y=1;
printf("Scenario #%d:\n",k++);
if(dfs(1,1,1))
for(i=0;i<n*m;i++)
printf("%c%d",prim[i].y+'A'-1,prim[i].x);
else cout<<"impossible";
cout<<endl<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: