您的位置:首页 > 产品设计 > UI/UE

对BFS与DFS的一些看法 ( 以HDU 1242 Rescue为例 )

2014-04-08 12:22 417 查看

[align=left]Problem Description[/align]
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up,
down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

[align=left]Input[/align]
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

[align=left]Output[/align]
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

[align=left]Sample Input[/align]

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........


[align=left]Sample Output[/align]
[align=left]13[/align]

[align=left] [/align]
[align=left] 一开始看到最短路径,想都没想直接bfs,想着只要简单处理一下守卫的问题,快速打完代码,提交,WA。之后就陷入无限的郁闷了,后来发现了一些端倪,bfs计算的是最短路,如果这样处理:见到守卫就把步数加一,是行不通的。举个简单的例子,从a到一个r有两条步数相同的路,在bfs扩展节点时,单纯遇到守卫就直接对步数加一是不影响从r到a的距离的,这里一定要避免这样的误区:题目所求的最短时间并非最短路的步数加上打倒x的用时。想到这里,bfs看似就不怎么奏效了,不过可以再加处理bfs是可行的。这里不细说了。[/align]
[align=left] 那么,可否换一种思路,求最短路用DFS? 这是可行的,而且思路异常简单,搜索到r的每条路径,找到最短,加上一些剪枝,绝不会超时。这样考虑的情况就变得简单明了。 好了,DFS打完,提交,WA。这次是真吐血了,无奈搜题解,发现竟然是friends!于是乎把a和r调换,AC之。[/align]
[align=left] dfs和bfs没有好坏之分,什么样的场合找准对应的方法,偶尔转换一下思路,求最短路的题目 在数据不大的范围内,bfs不好解,完全可以采取dfs穷举求最短。下面是AC代码。[/align]

#include<stdio.h>
#include<string.h>
int n,m,ok,ans,vis[205][205];
char mat[205][205];
void dfs(int x,int y,int step)
{
if(vis[x][y] || mat[x][y]=='#' || step>=ans) return;  //step>=ans 为一处剪枝。
if(mat[x][y]=='r')
{
ok=1;
if(step<ans) ans=step;
return;
}
if(mat[x][y]=='x')
step++;
vis[x][y]=1;     //所有该返回的判断全部结束了,设置访问标记
dfs(x+1,y,step+1);
dfs(x-1,y,step+1);
dfs(x,y+1,step+1);
dfs(x,y-1,step+1);
vis[x][y]=0;     //清除标记
}
int main()
{
while(~scanf("%d %d%*c",&n,&m))
{
memset(mat,'#',sizeof(mat));
int i,j,sti,stj;
for(i=1; i<=n; i++)
{
for(j=1; j<=m; j++)
{
scanf("%c",&mat[i][j]);
if(mat[i][j]=='a')
{
sti=i;
stj=j;
}
}
getchar();
}
ok=0;
ans=100000;
dfs(sti,stj,0);
if(ok) printf("%d\n",ans);
else printf("Poor ANGEL has to stay in the prison all his life.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: