您的位置:首页 > 大数据 > 人工智能

hdu 1787 GCD Again (欧拉函数)

2014-04-08 12:15 507 查看

GCD Again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2257 Accepted Submission(s): 908


[align=left]Problem Description[/align]
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem:
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!

[align=left]Input[/align]
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.

[align=left]Output[/align]
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.

[align=left]Sample Input[/align]

2

4

0

[align=left]Sample Output[/align]

0
1

[align=left]Author[/align]
lcy

[align=left]Source[/align]
2007省赛集训队练习赛(10)_以此感谢DOOMIII

[align=left]Recommend[/align]
lcy | We have carefully selected several similar problems for you: 1788 1695 1573 1905 1299

模板题:

//0MS    200K    399 B    G++
#include<stdio.h>
int euler(int n)
{
int ret=1;
for(int i=2;i*i<=n;i++){
if(n%i==0){
n/=i;ret*=i-1;
while(n%i==0){
n/=i;ret*=i;
}
}
}
if(n>1) ret*=n-1;
return ret;
}
int main(void)
{
int n;
while(scanf("%d",&n),n)
{
printf("%d\n",n-euler(n)-1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: