您的位置:首页 > 其它

POJ3104_DRYING_二分

2014-04-06 00:32 387 查看
题目描述

Drying

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8130 Accepted: 2065
Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at
a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount
of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount
of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output
sample output #1
3

sample output #2
2


解题报告

电吹风吹衣服问题。

我们二分最短可以吹干所有衣物的时间。自然干的不需要吹,来不及干的吹干。。。

很简单

代码

#include <iostream>
#include <stdio.h>
#include <cstring>
long long a[100555],n,k;
using namespace std;
bool jud(long t)
{
long long res=t;

for(long i=1;i<=n;i++)
if(a[i]>t)
res-=((a[i]-t)%(k-1)>0?((a[i]-t)/(k-1))+1:(a[i]-t)/(k-1));
return res>=0?true:false;
}
long solve()
{
if(k<=1)
{
long long maximum=-1;
for(long i=1;i<=n;i++)
if(a[i]>maximum)
maximum=a[i];
return maximum;
}
long long mid,l=1,r=2e9 ;
while(l<r){
mid=(l+r)>>1;
if(jud(mid))
r=mid;
else
l=mid;
if(r-l==1)
if(jud(l))
return l;
else
return r;
}
return mid;
}
int main()
{

while(scanf("%d",&n)!=EOF){
for(long i=1;i<=n;i++)
scanf("%d",&a[i]);
scanf("%d",&k);
long long res=solve();

printf("%d\n",res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: