您的位置:首页 > 其它

HDU-1385-Minimum Transport Cost(floyd)

2014-04-05 18:11 351 查看
[align=left]Problem Description[/align]
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:

The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

 

[align=left]Input[/align]
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N

a21 a22 ... a2N

...............

aN1 aN2 ... aNN

b1 b2 ... bN

c d

e f

...

g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and
g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

 

[align=left]Output[/align]
From c to d :

Path: c-->c1-->......-->ck-->d

Total cost : ......

......

From e to f :

Path: e-->e1-->..........-->ek-->f

Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

[align=left]Sample Input[/align]

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

 

[align=left]Sample Output[/align]

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

 
题意:给n个城市,输出任意一个城市到另一个城市的最小价格,其中通过的城市要收税,如果价值一样的输出最小字典序的路径。

思路:用path二维数组保存路径。

#include <stdio.h>
#define INF 99999999
#define MAX 35

int path[MAX][MAX],map[MAX][MAX],tax[MAX];

int main()
{
int n,i,j,k,len;

while(~scanf("%d",&n) && n)
{
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
scanf("%d",&k);

if(k==-1) map[i][j]=INF;
else map[i][j]=k;

path[i][j]=j;//初始化路径
}
}

for(i=1;i<=n;i++) scanf("%d",&tax[i]);

for(k=1;k<=n;k++)
{
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
len=map[i][k]+map[k][j]+tax[k];
if(len<map[i][j])//如果价值比原来的小
{
map[i][j]=len;
path[i][j]=path[i][k];//跟新路径
}
else if(len==map[i][j] && path[i][k]<path[i][j])//如果价值相等并且字典序比原来的小
{
path[i][j]=path[i][k];//跟新路径
}
}
}
}

while(scanf("%d%d",&i,&j) && i!=-1)
{
printf("From %d to %d :\nPath: ",i,j);

k=i;
while(k!=j)
{
printf("%d-->",k);
k=path[k][j];
}
printf("%d\nTotal cost : %d\n\n",j,map[i][j]);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: