您的位置:首页 > 其它

AOJ-AHU-OJ-186 Color Me Less

2014-04-05 13:41 337 查看
Color Me Less

Time Limit: 1000 ms   Case Time Limit: 1000 ms   Memory Limit: 64 MB

Description

A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target set of sixteen RGB color
values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255. The distance between
two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation 



Input

The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped. The input is terminated by a line
containing three -1 values.

Output

For each color to be mapped, output the color and its nearest color from the target set. 

If there are more than one color with the same smallest distance, please output the color given first in the color set.

Sample Input
OriginalTransformed
0 0 0
255 255 255
0 0 1
1 1 1
128 0 0
0 128 0
128 128 0
0 0 128
126 168 9
35 86 34
133 41 193
128 0 128
0 128 128
128 128 128
255 0 0
0 1 0
0 0 0
255 255 255
253 254 255
77 79 134
81 218 0
-1 -1 -1


Sample Output
OriginalTransformed
(0,0,0) maps to (0,0,0)
(255,255,255) maps to (255,255,255)
(253,254,255) maps to (255,255,255)
(77,79,134) maps to (128,128,128)
(81,218,0) maps to (126,168,9)


[align=center]————————————————————清明节分割线————————————————————[/align]
[align=center]思路:题意读懂了就行。套公式,求出所询问点与事先给出的16个点中欧几里得距离最小的点。不需要开根号,直接求距离的平方[/align]
[align=center]代码如下:[/align]
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
typedef struct {
int R, G, B;
}Node;
Node color[16];
int main() {
for(int i = 0; i < 16; i++)
scanf("%d%d%d", &color[i].R, &color[i].G, &color[i].B);
int rr, gg, bb, ans;
while(scanf("%d%d%d", &rr, &gg, &bb), rr!=-1&&gg!=-1&&bb!=-1) {
int mini = 1000000;
for(int i = 0; i < 16; i++) {
int D = (color[i].R-rr)*(color[i].R-rr) + (color[i].G-gg)*(color[i].G-gg) + (color[i].B-bb)*(color[i].B-bb);
if(!D)  {ans = i; break;}
if(D < mini) {
mini = D;
ans = i;
}
}
printf("(%d,%d,%d) maps to (%d,%d,%d)\n", rr, gg, bb, color[ans].R, color[ans].G, color[ans].B);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: