您的位置:首页 > 其它

10055 - Hashmat the Brave Warrior

2014-04-04 23:21 381 查看


10055 - Hashmat the Brave Warrior

Time limit: 3.000 seconds

Problem A
Hashmat the brave warrior
Input:standard input
Output:standard output

Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before fighting he just calculates one thing, the difference
between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Hashmat's soldier number is never greater than his opponent.

Input
The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input
numbers are not greater than 2^32. Input is terminated by End of File.

Output
For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.

Sample Input:
10 12

10 14

100 200

[b]Sample Output:[/b]
2

4

100

#include<stdio.h>

int main(){

long long m,n;

while(~scanf("%lld %lld",&m,&n)){

printf("%lld\n",m>n?m-n:n-m);

}

return 0;

}

这样更为简单:for(long long m,n;scanf("%lld %lld",&m,&n)!=EOF;){

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: