您的位置:首页 > 其它

poj 2362 Square

2014-04-04 22:46 246 查看
Square

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 19347 Accepted: 6712
Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
Sample Input
3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output
yes
no
yes

Source

Waterloo local 2002.09.21

1011的基础版

这道题就是说把输入的几根给定长度木棒拼成一个正方形,如果能拼成功则输出yes,否则输出no。

这题是用dfs外加剪枝解决的。

可以根据完成三条边的搜索就成立完成一次剪枝,总长被4整除第二次剪枝。。。

ac代码如下:

#include <cstdio>/*Problem:2362 User:motefly Memory: 724K Time: 329MS Language: G++ Result: Accepted*/
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN =10000;
int t,m,a[MAXN+10],xba;bool vis[MAXN+10];

int cmp(const void* a,const void* b)
{
return *(int*)b-*(int*)a;
}

bool dfs(int s,bool *vis,int len,int num)
{
if(num==3)
return true;
for(int i=s;i<m;i++)
{
if(vis[i])
continue;
vis[i]=true;
if(len+a[i]<xba)
{
if(dfs(i,vis,len+a[i],num))
return true;
}
else if(len+a[i]==xba)
if(dfs(0,vis,0,num+1))
return true;

vis[i]=false;
}
return false;
}

int main()
{
scanf("%d",&t);
while(t--)
{
int sum=0;
scanf("%d",&m);
memset(a,0,sizeof(a));
memset(vis,0,sizeof(vis));
for(int i=0;i<m;i++)
{
scanf("%d",&a[i]);
sum+=a[i];
}
if(m<4||sum%4)
{
cout<<"no"<<endl;
continue;
}
else {qsort(a,m,sizeof(int),cmp);
xba=sum/4;
dfs(0,vis,0,0) ? (cout<<"yes"<<endl) : (cout<<"no"<<endl);
}}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dfs poj acm 搜索 剪枝