您的位置:首页 > 其它

hdu 1018 Big Number (数学题)

2014-04-04 20:59 435 查看
Problem Description

Inmany applications very large integers numbers are required. Some of theseapplications are using keys for secure transmission of data, encryption, etc.In this problem you are given a number, you have to determine the number ofdigits in the
factorial of the number.

Input

Inputconsists of several lines of integer numbers. The first line contains aninteger n, which is the number of cases to be tested, followed by n lines, oneinteger 1 ≤ n ≤ 107 on each line.

Output

Theoutput contains the number of digits in the factorial of the integers appearingin the input.

SampleInput

2

10

20

Sample Output

7

19

/**************************************************

// 不能直接算N!,数据规模 1<N<10^7 太大,超出 2^31 的范围,所以取对数函数

// N = M*10^n n = log10(N) log10() 函数在头文件cmath中

984 MS,差点超时



************************************************/

#include <iostream>
#include<cmath>
using namespace std;
int main()
{
double sum;
int T,n;
cin>>T;
while(T--)
{
cin>>n;
sum = 1;
for(int i = 1;i<=n;i++)
sum+=log10(i);
cout<<(int)sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: