您的位置:首页 > 其它

ZOJ Problem Set - 1858 Soundex

2014-04-04 20:01 295 查看
Soundex coding groups together words that appear to sound alike based on their spelling. For example, "can" and "khawn", "con" and "gone" would be equivalent under Soundex coding.

Soundex coding involves translating each word into a series of digits in which each digit represents a letter:
1 represents B, F, P, or V

2 represents C, G, J, K, Q, S, X, or Z

3 represents D or T

4 represents L

5 represents M or N

6 represents R
The letters A, E, I, O, U, H, W, and Y are not represented in Soundex coding, and repeated letters with the same code digit are represented by a single instance of that digit. Words with
the same Soundex coding are considered equivalent.

Input

Each line of input contains a single word, all upper case, less than 20 letters long.

Output
For each line of input, produce a line of output giving the Soundex code.

Sample Input

KHAWN

PFISTER

BOBBY

Sample Output

25

1236

11
#include <cstdio>
#include <cstring>

using namespace std;

int main(void){
char change[27]="*123*12**22455*12623*1*2*2";
char input[21];
int i;
while(scanf("%s",input)!=EOF){
int len;
char temp,prev='0';
len=strlen(input);
for(i=0;i<len;i++){
temp=change[input[i]-'A'];
if(temp=='*'){
prev='0';
continue;
}
if(temp==prev) continue;
printf("%c",temp);
prev=temp;
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: