您的位置:首页 > 其它

POJ 1050 To the Max 最大子矩阵和 简单dp

2014-04-03 22:22 435 查看
Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 39056 Accepted: 20627

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines).
These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4

0 -2 -7 0 9 2 -6 2

-4 1 -4 1 -1

8 0 -2

Sample Output

15
/*AC*/
#include <stdio.h>
#include <string.h>
#include <iostream>

using namespace std;

int a[105][105], b[105];

int maxsum(int n) {
    int ans = b[0], r = b[0];
    for (int i = 1; i < n; i++) {
        if (r < 0)
            r = b[i];
        else
            r += b[i];
        if (r > ans)
            ans = r;
    }
    return ans;
}

int main() {
    int n;
    while (scanf("%d", &n) == 1) {
        for (int i = 0; i < n; i++)
            for (int j = 0; j < n; j++)
                scanf("%d", &a[i][j]);
        int ans = -1e9, sum;
        for (int i = 0; i < n; i++) {
            for (int k = 0; k < n; k++)
                b[k] = 0;
            for (int j = i; j < n; j++) {
                for (int k = 0; k < n; k++)
                    b[k] += a[j][k];
                sum = maxsum(n);
                if (sum > ans)
                    ans = sum;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: