您的位置:首页 > 其它

hdu3471之状态压缩dp

2014-04-03 13:40 148 查看
Most Powerful

Time Limit: 2 Seconds Memory Limit: 65536 KB

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and
a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.
You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.
Input
There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow.
There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.
The last case is followed by a 0 in one line.
There will be no more than 500 cases including no more than 50 large cases that N is 10.
Output
Output the maximal power these N atoms can produce in a line for each case.
Sample Input
2

0 4

1 0

3

0 20 1

12 0 1

1 10 0

0

Sample Output
4

22

简单状态压缩dp
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=(1<<10)+10;
int n;
int dp[MAX],poww[20][20];

void DP(){
	memset(dp,0,sizeof dp);
	int bit=1<<n;
	for(int i=0;i<bit;++i){//状态i,1表示该原子已被撞没,0表示还存在 
		for(int j=0;j<n;++j){
			if(i&(1<<j))continue;
			for(int k=0;k<n;++k){//用k去撞击j 
				if(j == k)continue;
				if(i&(1<<k))continue;
				dp[i|(1<<k)]=max(dp[i|(1<<k)],dp[i]+poww[j][k]);
			}
		}
	}
	int sum=0;
	for(int i=0;i<n;++i)sum=max(sum,dp[bit-1-(1<<i)]);//最后只剩下原子i 
	printf("%d\n",sum);
}

int main(){
	while(~scanf("%d",&n),n){
		for(int i=0;i<n;++i){
			for(int j=0;j<n;++j)scanf("%d",&poww[i][j]);
		}
		DP();
	}
	return 0;
}
/*
10
10000 10000 10000 10000 10000 10000 10000 10000 10000 10000
10000 10000 10000 10000 10000 10000 10000 10000 10000 10000
10000 10000 10000 10000 10000 10000 10000 10000 10000 10000
10000 10000 10000 10000 10000 10000 10000 10000 10000 10000
10000 10000 10000 10000 10000 10000 10000 10000 10000 10000
10000 10000 10000 10000 10000 10000 10000 10000 10000 10000
10000 10000 10000 10000 10000 10000 10000 10000 10000 10000
10000 10000 10000 10000 10000 10000 10000 10000 10000 10000
10000 10000 10000 10000 10000 10000 10000 10000 10000 10000
10000 10000 10000 10000 10000 10000 10000 10000 10000 10000
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: