您的位置:首页 > 其它

POJ 2387 Til the Cows Come Home

2014-04-03 13:10 369 查看
链接:http://poj.org/problem?id=2387

题目:

Til the Cows Come Home

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 27055Accepted: 9102
Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various
lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output
90


解题思路:

一个简单的单源最短路问题。可以用dijkstra,也可以用spfa。这里我是用spfa来写的。第一次使用spfa。spfa与dijkstra相比有不少优点:能处理边权为负的情况。基本思想:动态逼近法,使用队列存储待优化的节点,优化时每次取出队首节点u,用u的dis值对u点出边所指向的节点v惊醒松弛操作。如果v的dis值有所调整,v不在队列q中,则将v入队。

代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;

#define INF 0x7fffffff
#define min(x,y) x<y?x:y
const int MAXN = 1010;
int n, map[MAXN][MAXN], vis[MAXN], dis[MAXN];

int spfa(int s)
{
	queue<int> q;
	dis[s] = 0, vis[s] = 1, q.push(s);
	while(!q.empty())
	{
		int t = q.front();
		q.pop();
		for(int i = 1; i <= n; i++)
		{
			if(dis[t] < dis[i] - map[t][i])
			{
				dis[i] = dis[t] + map[t][i];
				if(!vis[i])
				{
					vis[i] = 1;
					q.push(i);
				}
			}
		}
		vis[t] = 0;
	}
	return dis[1];
}

int main()
{
	int t;
	
	while(~scanf("%d%d", &t, &n))
	{
		for(int i = 1; i <= MAXN; i++)
		{
			dis[i] = INF;
			for(int j = 1; j <= MAXN; j++)
			{
				map[i][j] = INF;
			}
		}
		memset(vis, 0, sizeof(vis));
		
		for(int i = 0; i < t; i++)
		{
			int a, b, c;
			scanf("%d%d%d", &a, &b, &c);
			map[a][b] = map[b][a] = min(map[a][b], c);
		}
		
		printf("%d\n", spfa(n));
	}
	
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: