您的位置:首页 > 其它

hdu 3584 Cube (三维树状数组)

2014-04-01 21:50 357 查看

Cube

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1307 Accepted Submission(s): 674


[align=left]Problem Description[/align]
Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N).
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].

[align=left]Input[/align]
Multi-cases.
First line contains N and M, M lines follow indicating the operation below.
Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation.
If X is 1, following x1, y1, z1, x2, y2, z2.
If X is 0, following x, y, z.

[align=left]Output[/align]
For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)

[align=left]Sample Input[/align]

2 5
1 1 1 1 1 1 1

0 1 1 1

1 1 1 1 2 2 2
0 1 1 1
0 2 2 2

[align=left]Sample Output[/align]

1

0
1

[align=left]Author[/align]
alpc32

[align=left]Source[/align]
2010 ACM-ICPC Multi-University Training Contest(15)——Host by NUDT

[align=left]Recommend[/align]
zhouzeyong | We have carefully selected several similar problems for you: 3450 1541 1892 2492 3743

//203MS    4784K    1280 B    G++
/*

题意和原理都和poj 的2155 差不多,这题多了一维而已。

*/
#include<stdio.h>
#include<string.h>
#define N 105
int c

;
int lowbit(int i)
{
return i&(-i);
}
int update(int x,int y,int z)
{
int s=0;
for(int i=x;i<N;i+=lowbit(i))
for(int j=y;j<N;j+=lowbit(j))
for(int k=z;k<N;k+=lowbit(k))
s+=c[i][j][k];
return s%2;
}
void getsum(int x,int y,int z)
{
for(int i=x;i>0;i-=lowbit(i))
for(int j=y;j>0;j-=lowbit(j))
for(int k=z;k>0;k-=lowbit(k))
c[i][j][k]^=1;
}
int main(void)
{
int n,m;
int op,x1,x2,y1,y2,z1,z2;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(c,0,sizeof(c));
while(m--){
scanf("%d",&op);
if(op==0){
scanf("%d%d%d",&x1,&y1,&z1);
printf("%d\n",update(x1,y1,z1));
}else if(op==1){
scanf("%d%d%d%d%d%d",&x1,&y1,&z1,&x2,&y2,&z2);
getsum(x1-1,y1-1,z1-1);
getsum(x1-1,y1-1,z2);
getsum(x1-1,y2,z1-1);
getsum(x2,y1-1,z1-1);
getsum(x2,y1-1,z2);
getsum(x1-1,y2,z2);
getsum(x2,y2,z1-1);
getsum(x2,y2,z2);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: