您的位置:首页 > 产品设计 > UI/UE

HDOJ --- 1159 Common Subsequence

2014-04-01 16:37 274 查看

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20815 Accepted Submission(s): 8954


[align=left]Problem Description[/align]
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

[align=left]Sample Input[/align]

abcfbc abfcab
programming contest
abcd mnp

[align=left]Sample Output[/align]

4 2 0
思路:dp[i][j]表示str1的第i-1个字符和str2的第j-1个字符的最大的LCS,str[i-1] == str[j-1]时,dp[i][j] = dp[i-1][j-1] + 1 ; else : dp[i-1][j-1] = max(dp[i-1][j],dp[i][j-1]) .



#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
string str1, str2;
int dp[2005][2005];
int main(){
/* freopen("in.c", "r", stdin); */
while(cin >> str1 >> str2){
memset(dp, 0, sizeof(dp));
for(int i = 1;i <= str1.size();i ++){
for(int j = 1;j <= str2.size();j ++){
if(str1[i-1] == str2[j-1]) dp[i][j] = dp[i-1][j-1] + 1;
else dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
}
}
printf("%d\n", dp[str1.size()][str2.size()]);
str1.clear(), str2.clear();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: