您的位置:首页 > 其它

HDOJ4245_A Famous Music Composer

2014-03-30 17:00 337 查看


A Famous Music Composer

Problem Description

Mr. B is a famous music composer. One of his most famous work was his set of preludes. These 24 pieces span the 24 musical keys (there are musically distinct 12 scale notes, and each may use major or minor tonality). The 12 distinct scale notes are:



Five of the notes have two alternate names, as is indicated above with equals sign. Thus, there are 17 possible names of scale notes, but only 12 musically distinct notes. When using one of these as the keynote for a musical key, we can further distinguish
between major and minor tonalities. This gives 34 possible keys, of which 24 are musically distinct.

In naming his preludes, Mr. B used all the keys except the following 10, which were named instead by their alternate names:



Write a program that, given the name of a key, give an alternate name if it has one, or report the key name is unique.

Input

Each test case is described by one line having the format "note tonality", where "note" is one of the 17 names for the scale notes given above, and "tonality" is either "major" or "minor" (quotes for clarify).

Output

For each case output the required answer, following the format of the sample.

Sample Input

Ab minor
D# major
G minor


Sample Output

Case 1: G# minor
Case 2: Eb major
Case 3: UNIQUE


代码:
#include <iostream>
#include <string>
using namespace std;
int main(){
string a,b;
int count=1;
while(cin>>a>>b){
if(a=="A"||a=="B"||a=="C"||a=="D"||a=="E"||a=="F"||a=="G"){
cout<<"Case "<<count<<": "<<"UNIQUE"<<endl;count++;}
if(a=="A#")   { cout<<"Case "<<count<<": "<<"Bb"<<" "<<b<<endl;count++;}
if(a=="Bb") { cout<<"Case "<<count<<": "<<"A#"<<" "<<b<<endl;count++;}
if(a=="C#") { cout<<"Case "<<count<<": "<<"Db"<<" "<<b<<endl;count++;}
if(a=="Db") { cout<<"Case "<<count<<": "<<"C#"<<" "<<b<<endl;count++;}
if(a=="D#") { cout<<"Case "<<count<<": "<<"Eb"<<" "<<b<<endl;count++;}
if(a=="Eb") { cout<<"Case "<<count<<": "<<"D#"<<" "<<b<<endl;count++;}
if(a=="F#") { cout<<"Case "<<count<<": "<<"Gb"<<" "<<b<<endl;count++;}
if(a=="Gb") { cout<<"Case "<<count<<": "<<"F#"<<" "<<b<<endl;count++;}
if(a=="G#") { cout<<"Case "<<count<<": "<<"Ab"<<" "<<b<<endl;count++;}
if(a=="Ab") { cout<<"Case "<<count<<": "<<"G#"<<" "<<b<<endl;count++;}
}
return 0;
}
思路不解释,我用了最简单的思路!!!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: