您的位置:首页 > 其它

ZOJ 3706 Break Standard Weight(深搜处理)

2014-03-30 15:46 381 查看
Break Standard Weight
Time Limit: 2 Seconds      Memory Limit: 65536 KB
The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam,
with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term "scales" for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the
beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.
With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5,
we can measure the object with mass 145 or 6 exactly.
In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts,
whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5,
you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9,
10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.

Input

There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y.
2 ≤ x, y ≤ 100

Output

For each test case, output the maximum number of possible special masses.

Sample Input

2
4 9
10 10

Sample Output

13
9


题意:两个正整数的砝码,把其中一个分成正整数的部分,用这三个砝码能称量哪些重量(正整数)。
思路:枚举分哪一个,每个分多少,然后dfs

#include<cstdio>
#include<string.h>
#include<iostream>
#include<queue>
#include<algorithm>

const int maxn = 300;
using namespace std;

int vis[maxn];
int ans=0,cnt=0;
int num[3];

void dfs(int count,int now)
{
if(! vis[now] && now > 0)
{
cnt++;
vis[now] = 1;
}
if(count == 3)return ;
dfs(count + 1,now + num[count]);
dfs(count + 1,now - num[count]);
dfs(count + 1,now);
}

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int x,y;
scanf("%d%d",&x,&y);
ans=0;
int i;
for(i = 1;i <= x; i++)
{
memset(vis,0,sizeof(vis));
num[0] = i,num[1] = x - i,num[2] = y;
cnt = 0;
dfs(0,0);
ans = max(ans,cnt);
}
for(i = 1;i <= y; i++)
{
memset(vis,0,sizeof(vis));
num[0] = i,num[1] = y - i,num[2] = x;
cnt = 0;
dfs(0,0);
ans = max(ans,cnt);
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: