您的位置:首页 > 其它

POJ 3728 Catch That Cow (广搜)

2014-03-30 15:05 162 查看
Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 42564 Accepted: 13225
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17

Sample Output
4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include<cstdio>
#include<string.h>
#include<iostream>
#include<queue>
#include<algorithm>

using namespace std;

int vis[100010];
int n,k;

struct stu
{
int ans;
int sum;
};

int bfs()
{
queue <stu> q;
//    while(q.size())
//        q.pop();
memset(vis,0,sizeof(vis));
stu kaishi={n,0};
q.push(kaishi);
vis[kaishi.ans]=1;
while(q.size())
{
stu xian=q.front();
stu xia;
q.pop();
int i;
for(i=0;i<3;i++)
{
if(i==0) xia.ans=xian.ans+1;
if(i==1) xia.ans=xian.ans-1;
if(i==2) xia.ans=xian.ans*2;
xia.sum=xian.sum+1;
if(xia.ans==k)
return xia.sum;
if(xia.ans>=0&&xia.ans<=100010&&!vis[xia.ans])
{
vis[xia.ans]=1;
q.push(xia);
}
}
}
return 0;
}

int main()
{

while(scanf("%d%d",&n,&k)!=EOF)
{
if(n>=k)
{
printf("%d\n",n-k);
}
else
printf("%d\n",bfs());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: