您的位置:首页 > 编程语言 > C语言/C++

Pat(Advanced Level)Practice--1050(String Subtraction)

2014-03-29 21:00 267 查看

Pat1050代码

题目描述:

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from
S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104.
It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.
Sample Input:
They are students.
aeiou

Sample Output:
Thy r stdnts.


AC代码:
#include<cstdio>
#include<cstdlib>
#include<map>
#define MAX 10005

using namespace std;

int main(int argc,char *argv[])
{
char s1[MAX],s2[MAX];
int i;
char c;
map<char,int> m;
gets(s1);
gets(s2);
for(i=0;s1[i]!='\0';i++)
{
c=s1[i];
m[c]++;
}
for(i=0;s2[i]!='\0';i++)
{
c=s2[i];
m[c]=0;
}
for(i=0;s1[i]!='\0';i++)
{
c=s1[i];
if(m[c]!=0)
printf("%c",c);
}
printf("\n");

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Advance Pat C++ 基础题