您的位置:首页 > 产品设计 > UI/UE

hdu Children's queue

2014-03-29 00:00 357 查看
Children’s Queue
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 75   Accepted Submission(s) : 19

Font: Times New Roman | Verdana |
Georgia

Font Size: ← →

Problem Description

There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands
side by side. The case n=4 (n is the number of children) is like

FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM

Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

Input

There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

Output

For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

Sample Input

1
2
3


Sample Output

1
2
4


题目大意:一个排队游戏,假如有n个人,排成一排,规则:女生必须至少两个站一起,男生随便站。问有多少种站法。

解题思路:此题明显是一个递推问题,在此规定n个人排队共有f(n)种排法。

(1)假如第n个人是男生则有f(n-1)种排法。

(2)若第n个人是女生则第n-1个人一定是女生,此种情况又分两种。一是,若第n-2个人是男生的话,则有f(n-2)。第二种情况,第n-2个人是女生则要满足题意则队形应是

f(n-4)+男+女;

综上所诉此题满足的递推关系式为f(n)=f(n-1)+f(n-2)+f(n-4);

注意此题还涉及到超大数处理。

代码:

#include <stdio.h>

int a[1001][1001]={0};

int main()

{

    int n,m,i,j,t,l;

    a[1][1]=1,a[2][1]=2,a[3][1]=4,a[4][1]=7;

        m=0;

       //把1000以内所有的数据都计算出来,这样就不用每输入一个数都要从a[1]算起,更节省时间。

        for(j=5;j<=1000;j++)

        {

            for(i=0;i<1001;i++)

            {

                m+=a[j-1][i]+a[j-2][i]+a[j-4][i];

                a[j][i]=m%10;//每次磨10取余算出本位的数,放入对应的数组序号里

                m/=10;//求进位数

            }

            while(m)//对最高的一位做特殊处理

            {

                a[j][t++]=m%10;

                m/=10;

            }

        }

    while(scanf("%d",&n)!=EOF)

    {

        for(i=1000;i>=0;i--)//从头找到第一个不为零的数

            if(a
[i]!=0)

                break;

            printf("%d",a
[i]);//输出结果

        for(l=i-1;l>=1;l--)

            printf("%d",a
[l]);

        printf("\n");

    }

return 0;

}

为了进一步节约时间可以采用下面每四位存到一个数组变量里,采用四位四位的输出方法,计算所有的f(n)时每次循环由1001次减少到101次。

代码:

#include <stdio.h>

int a[1001][101]={0};

int main()

{

    int n,m,i,j,t,l;

    a[1][1]=1,a[2][1]=2,a[3][1]=4,a[4][1]=7;

        m=0;

        for(j=5;j<=1000;j++)

        {

            for(i=0;i<101;i++)

            {

                m+=a[j-1][i]+a[j-2][i]+a[j-4][i];

                a[j][i]=m%10000;

                m/=10000;

            }

            while(m)

            {

                a[j][t++]=m%10000;

                m/=10000;

            }

        }

    while(scanf("%d",&n)!=EOF)

    {

        for(i=100;i>=0;i--)

            if(a
[i]!=0)

                break;

            printf("%d",a
[i]);

        for(l=i-1;l>=1;l--)

            printf("%04d",a
[l]);//注意:四位四位的输出格式是%04d

        printf("\n");

    }

return 0;

}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: