您的位置:首页 > 编程语言 > C语言/C++

ACM HDU Primes(素数判断)

2014-03-28 19:29 363 查看
Problem Description
Writea program to read in a list of integers and determine whether or not eachnumber is prime. A number, n, is prime if its only divisors are 1 and n. Forthis problem, the numbers 1 and 2 are not considered primes. 
 
 
Input
Eachinput line contains a single integer. The list of integers is terminated with anumber<= 0. You may assume that the input contains at most 250 numbers andeach number is less than or equal to 16000.
 
 
Output
Theoutput should consists of one line for every number, where each line firstlists the problem number, followed by a colon and space, followed by"yes" or "no". 
 
 
Sample Input
1
2
3
4
5
17
0
 
 
Sample Output
1: no
2: no
3: yes
4: no
5: yes
6: yes
 
/************************************************************************
简单数论,判断素数,,,
**************************************************/

#include<stdio.h>
bool prime(int n)
{
if(n<=2)
return false;// 这题好奇葩, 1,2不算素数
for(int i = 2;i*i<=n;i++)
if(n%i==0)
return false;
return true;
}
int main()
{
int n,count = 0;// 注意输出时前面的数字是计数的,而不是输入的数字
while(scanf("%d",&n)&&n>0)
{
count++;
if(prime(n))
printf("%d: yes\n",count);
else
printf("%d: no\n",count);
}
return 0;
}

//  虽然很简单,但是想记下来,慢慢积累。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM hdu C++ 数论 素数