您的位置:首页 > Web前端

poj 2492 A Bug's Life (并查集)

2014-03-28 17:14 591 查看
A Bug's Life

Time Limit: 10000MSMemory Limit: 65536K
Total Submissions: 26599Accepted: 8676
Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.
Source

TUD Programming Contest 2005, Darmstadt, Germany

//Accepted    140K    735MS    C++    821B    2014-03-28 17:12:00
/*

分类并查集,思想和2492差不多。

*/
#include<stdio.h>
#define N 2000
int set[2*N+1];
int find(int x)
{
if(x==set[x]) return x;
return set[x]=find(set[x]);
}
int main(void)
{
int t,n,m,a,b,k=1;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=0;i<=n+N;i++) set[i]=i;
int flag=0;
for(int i=0;i<m;i++){
scanf("%d%d",&a,&b);
int x=find(a);
int y=find(b);
int tx=find(a+N);
int ty=find(b+N);
if(x==y){
flag=1;continue;
}
set[x]=ty;
set[y]=tx;
}
printf("Scenario #%d:\n",k++);
if(flag) puts("Suspicious bugs found!");
else puts("No suspicious bugs found!");
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: