您的位置:首页 > 其它

hdu 3038 How Many Answers Are Wrong (并查集)

2014-03-28 09:53 344 查看

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2045 Accepted Submission(s): 807


[align=left]Problem Description[/align]
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).



Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

[align=left]Input[/align]
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

[align=left]Output[/align]
A single line with a integer denotes how many answers are wrong.

[align=left]Sample Input[/align]

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

[align=left]Sample Output[/align]

1

[align=left]Source[/align]
2009 Multi-University Training Contest 13 - Host by HIT

[align=left]Recommend[/align]
gaojie | We have carefully selected several similar problems for you: 3035 3036 3037 3031 3034

核心思想和

3635Dragon Balls
类似。都是要路径压缩,然后在路径压缩的过程中更新点的值。

//62MS    1428K    1051 B    G++
/*

题意:
给出m个关系,每个关系表示[a,b]的和为s。问有多少个是错误的。

并查集:
sum[i]表示第i个点到其根节点之间的数的和。

*/
#include<stdio.h>
#include<string.h>
#define N 200005
int set
,sum
;
int find(int x)
{
if(x!=set[x]){
int t=set[x];
set[x]=find(set[x]);
sum[x]+=sum[t]; //加上将改变前的根节点的值
}
return set[x];
}
int merge(int a,int b,int s)
{
int x=find(a);
int y=find(b);
if(x==y){
if(sum[a]-sum[b]!=s) return 1; //如果在同一集合(即两端都已算出),如果其S与其差值不等证明其错误
}else{
if(x<y){
set[x]=y;
sum[x]=sum[b]-sum[a]+s;
//printf("**%d %d %d\n",sum[x],sum[b],sum[a]);
}else{
set[y]=x;
sum[y]=sum[a]-sum[b]-s;
//printf("**%d %d %d\n",sum[y],sum[b],sum[a]);
}
}
return 0;
}
int main(void)
{
int n,m;
int a,b,s;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=0;i<=n;i++){
set[i]=i;
sum[i]=0;
}
int ans=0;
for(int i=0;i<m;i++){
scanf("%d%d%d",&a,&b,&s);
if(merge(a-1,b,s)) ans++; //注意是a-1
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: