您的位置:首页 > 其它

动态规划--模板--hdu 1059 Dividing

2014-03-27 14:32 323 查看


Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14861    Accepted Submission(s): 4140


Problem Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in
half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the
same total value. 

Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets
of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

 

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2
0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

 

Output

For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.

 

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

 

Source

Mid-Central European Regional Contest 1999

题意:

        价值分别为1,2,3,4,5,6的6件物品,每件有ni件(ni<=20000),问是否能分成等价值的两份!

       较好的动态规划模板题!

#include "stdio.h"
#include "string.h"
#define N 120005
int a[7],map
;
int sum;

int MAX(int x,int y)
{
if(x>y) return x;
return y;
}

void CompletePack(int cost,int weight)   //完全背包
{
for(int i=cost;i<=sum;i++)
map[i] = MAX(map[i],map[i-cost]+weight);
}

void ZeroOnePack(int cost,int weight)    // 01背包
{
for(int i=sum;i>=cost;i--)
map[i] = MAX(map[i],map[i-cost] + weight);
}

void dp(int cost,int weight,int k)
{
if(cost*k>=sum)
CompletePack(cost,weight);
else
{
for(int j=1;j<k; )   //二进制优化
{
ZeroOnePack(j*cost,j*weight);
k-=j;
j*=2;
}
ZeroOnePack(k*cost,k*weight);
}
}

int main()
{
int i,p=1;
while(1)
{
sum=0;
for(i=1;i<=6;i++)
{
scanf("%d",&a[i]);
sum+=a[i]*i;
}
if(sum==0) return 0;
printf("Collection #%d:\n",p++);
if(sum%2==1)
{
printf("Can't be divided.\n\n");
continue;
}
sum=sum/2;
memset(map,0,sizeof(map));
for(i=1;i<=6;i++)
dp(i,i,a[i]);
if(map[sum]==sum)
printf("Can be divided.\n\n");
else
printf("Can't be divided.\n\n");
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划