您的位置:首页 > 其它

POJ 1146 求字符串的下一个排列

2014-03-27 11:56 162 查看
ID Codes

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5741 Accepted: 3436
Description
It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a
radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored
by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.)

An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code
is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable
from it are used before changing the set.

For example, suppose it is decided that a code will contain exactly 3 occurrences of `a', 2 of `b' and 1 of `c', then three of the allowable 60 codes under these conditions are:

abaabc

abaacb

ababac


These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order.

Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message `No Successor'
if the given code is the last in the sequence for that set of characters.

Input
Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #.

Output
Output will consist of one line for each code read containing the successor code or the words 'No Successor'.

Sample Input
abaacb
cbbaa
#

Sample Output
ababac
No Successor

Source
New Zealand 1991 Division I,UVA 146

给定一个字符串,输出它的下一个排列。

解法:首先找到最后一个正序的i,使得str[i-1]<=str[i],如果不存在,则说明不存在下一个排列,然后从i开始向后找到最小的字符str[j],使得str[j]>str[i-1],然后交换str[j]与str[i-1],然后把i-1后面的字典序排列,就可以得到答案。

代码:

/* ***********************************************
Author :rabbit
Created Time :2014/3/27 10:27:30
File Name :7.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
char str[100];
int get(char *str){
int len=strlen(str);
int i=len-1;
while(i&&str[i-1]>=str[i])i--;
if(!i)return 0;
int mp=i;
for(int j=i+1;j<len;j++)
if(str[j]>str[i-1]&&str[j]<str[mp])mp=j;
swap(str[mp],str[i-1]);
sort(str+i,str+len);
return 1;
}
int main()
{
//freopen("data.in","r",stdin);
//freopen("data.out","w",stdout);
while(~scanf("%s",str)&&str[0]!='#'){
if(get(str))printf("%s\n",str);
else puts("No Successor");
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: