您的位置:首页 > 编程语言 > C语言/C++

LIGHTOJ 1005

2014-03-26 19:19 330 查看
A - LIGHTOJ 1005
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status

Description

A rook is a piece used in the game of chess which is played on a board of square grids. A rook can only move vertically or horizontally from its current position and two rooks attack each other if one is on the path of the other. In the following figure,
the dark squares represent the reachable locations for rook R1 from its current position. The figure also shows that the rook R1 and R2 are in attacking positions where R1 and R3 are
not. R2 andR3 are also in non-attacking positions.



Now, given two numbers n and k, your job is to determine the number of ways one can put k rooks on an n x nchessboard so that no two of them are in attacking positions.

Input

Input starts with an integer T (≤ 350), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 30) and k (0 ≤ k ≤ n2).

Output

For each case, print the case number and total number of ways one can put the given number of rooks on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1017.

Sample Input

8

1 1

2 1

3 1

4 1

4 2

4 3

4 4

4 5

Sample Output

Case 1: 1

Case 2: 4

Case 3: 9

Case 4: 16

Case 5: 72

Case 6: 96

Case 7: 24

Case 8: 0

#include <stdio.h>
#include <math.h>
#include <string.h>
#define LL long long
int zuhe[31][31];
int main()
{
memset(zuhe,0,sizeof(zuhe));
for(int i=1;i<=30;i++)
{zuhe[i][1]=i;zuhe[i][0]=1;}
for(int i=2;i<=30;i++)
for(int j=1;j<=i;j++)
{
zuhe[i][j]=zuhe[i-1][j]+zuhe[i-1][j-1];
}
int m;
freopen("input.txt","r",stdin);
scanf("%d",&m);
LL ans=0;
int N,K,count=1;
while(m--)
{
scanf("%d%d",&N,&K);
printf("Case %d: ",count);count++;
if(K>N)printf("0\n");
else
{
if(K==0)printf("1\n");
else
{
LL n=zuhe
[K];
ans=n*n;
for(int i=1;i<=K;i++)
ans*=i;
printf("%lld\n",ans);
}
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  组合公式 acm 数学 c++