您的位置:首页 > 其它

1078. Hashing (25)

2014-03-25 05:59 447 查看

1078. Hashing (25)

时间限制
100 ms

内存限制
32000 kB

代码长度限制
16000 B

判题程序
Standard

作者
CHEN, Yue

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table.
Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers
are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert
the number, print "-" instead.

Sample Input:
4 4
10 6 4 15

Sample Output:
0 1 4 -


不知道为什么,把a设成全局变量,放到main函数外面就全对了,,,,

1.知道真相的我眼泪掉下来啊,是因为数组开得太大,所以需要再main函数外面么

#include<iostream>

using namespace std;
int a[10000]={0};

bool isPr(int mm){
if(mm==1) return false;
if(mm==2) return true;
for(int i=2;i*i<=mm;i++){
if(mm%i==0){
return false;
}
}
return true;
}

int main(){
int Msize,K;
//freopen("in.txt","r",stdin);

scanf("%d %d",&Msize,&K);
while(!isPr(Msize)){
Msize++;
}
//	cout<<Msize<<endl;
bool flag=true;
int j;
while(K--){
int temp;
scanf("%d",&temp);
if(flag){
flag=false;
}else{
cout<<" ";
}
int index;
for(j=0;j<Msize;j++){
int ttt=temp+j*j;
index=ttt%Msize;
if(a[index]==0){
a[index]=1;
printf("%d",index);
break;
}
}
if(j==Msize){
printf("-");
}
}

return 0;
}


,改了一份网上的代码,看看自己哪里错了
#include <stdio.h>
#include <math.h>
#include <string.h>
int MSize, N;
bool list[10010];
int hash[10100];
bool IsPrime(int num)
{
if(num == 1)
{
return false;
}
else if(num == 2)
{
return true;
}
else if(num % 2 == 0)
{
return false;
}
bool res = true;
int temp = sqrt((double)num);
for(int i = 3; i <= temp; i += 2)
{
if(num % i == 0)
{
res = false;
break;
}
}
return res;
}
int main()
{
//	freopen("in.txt","r",stdin);
while(scanf("%d %d", &MSize, &N) != EOF)
{
memset(list, false, sizeof(list));
while(!IsPrime(MSize))
{
MSize++;
}
int temp,index;
for(int i = 0; i < N; i++)
{
scanf("%d", &temp);
hash[i] = -1;
int j = 0;
if(i!=0){
printf(" ");
}
for( j = 0; j < MSize; j++)
{
index = (temp + j * j) % MSize;
if(!list[index])
{
list[index] = true;
hash[i] = index;
printf("%d",index);
break;
}
}
if(j==MSize){
printf("-");
}

}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: