您的位置:首页 > 其它

hdu 1058 Humble Numbers

2014-03-24 21:06 309 查看

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15301 Accepted Submission(s): 6631



[align=left]Problem Description[/align]
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

[align=left]Input[/align]
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

[align=left]Output[/align]
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

[align=left]Sample Input[/align]

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0


[align=left]Sample Output[/align]

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.


[align=left]Source[/align]
University of Ulm Local Contest 1996

[align=left]Recommend[/align]
JGShining | We have carefully selected several similar problems for you: 1159 1069 1087 1176 1421

同动态规划题,我刚开始的想法是把所有为7以上质数倍数的数挑出来,把未挑出来的数保存在数组中,但是超时了
实在忍不住百度发现了别人的思路是从a[1]=1开始把所有满足条件的数找出来
递归公式是a[i]=min{ 2*a[c1], 3*a[c2], 5*a[c3], 7*a[c4] }
有思路了就好做了
代码如下:
#include <map>
#include <cmath>
#include <vector>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#define esp 1e-9
#define MAXN 6000
#define ll long long
#define INF 0x7FFFFFFF
#define SW(a,b) a^=b;b^=a;a^=b;
#define rep(i,j,k) for(int i=j; i<k; ++i)
#define REP(i,j,k) for(int i=j; i<=k; ++i)
using namespace std;
int a[MAXN] = {0};
int k = 2;
int main(void){
a[1] = 1;
int c1, c2, c3, c4;
c1 = c2 = c3 = c4 = 1;
REP(i, 2, 5842){
int t1 = 2*a[c1];
int t2 = 3*a[c2];
int t3 = 5*a[c3];
int t4 = 7*a[c4];
int min = t1;

if(min > t2) min = t2;
if(min > t3) min = t3;
if(min > t4) min = t4;

if(min == t1) c1++;
if(min == t2) c2++;
if(min == t3) c3++;
if(min == t4) c4++;

a[i] = min;
}
int n;
while(cin >> n && n){
printf("The %d", n);
if(n%10==1 && n%100!=11){
printf("st humble number is ", n);
}else if(n%10==2 && n%100!=12){
printf("nd humble number is ", n);
}else if(n%10==3 && n%100!=13){
printf("rd humble number is ", n);
}else printf("th humble number is ", n);
printf("%d.\n", a
);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: