您的位置:首页 > 其它

hdu1677--Nested Dolls(贪心+LIS)

2014-03-24 19:19 369 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1677

[align=left]Problem Description[/align]
Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and
this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll
and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble
from his massive list of measurements?

[align=left]Input[/align]
On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the
test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i.

[align=left]Output[/align]
For each test case there should be one line of output containing the minimum number of nested dolls possible.

[align=left]Sample Input[/align]

4
3
20 30 40 50 30 40
4
20 30 10 10 30 20 40 50
3
10 30 20 20 30 10
4
10 10 20 30 40 50 39 51


[align=left]Sample Output[/align]

1
2
3
2


题目大意:

先给出一些盒子,知道其宽w和高h,小盒子可以装到大盒子里边,其条件是w1<w2&&h1<h2,求最多能装几个 盒子。

这道题我实在不知道怎么做,看了别人的博客,感觉有点明白,但是没有真正的读懂..................................

代码实现:

#include <iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 20005
struct node
{
int h;
int w;
}a
;
int dp
;
int stack
;
int cmp(node a,node b)
{
if(a.w==b.w)
return a.h<b.h;
return a.w>b.w;
}
int lis(int n)
{
memset(dp,0,sizeof(dp));
memset(stack,0,sizeof(stack));
int top=0;
stack[top]=-99999999;
int maxx=-1;
for(int i=1; i<=n; i++)
{
if(a[i].h>=stack[top])
{
stack[++top]=a[i].h;
dp[i]=top;
}
else
{
int l=1,r=top;
while(l<=r)
{
int mid=(l+r)/2;
if(a[i].h>=stack[mid])
{
l=mid+1;
}
else
r=mid-1;
}
stack[l]=a[i].h;
dp[i]=l;
}
if(dp[i]>maxx)
maxx=dp[i];
}
return maxx;
}
int main()
{
int t,n;
cin>>t;
while(t--)
{
cin>>n;
for(int i=1; i<=n; i++)
{
cin>>a[i].w>>a[i].h;
}
sort(a+1,a+n+1,cmp);
int ans=lis(n);
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: