您的位置:首页 > 编程语言 > Go语言

poj 2000 Gold Coins

2014-03-24 12:05 399 查看
Gold Coins
Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 16229Accepted: 10172
DescriptionThe king pays his loyal knight in gold coins. Onthe first day of his service, the knight receives one gold coin. Oneach of the next two days (the second and third days of service),the knight receives two gold coins. On each of the next three days(the fourth,
fifth, and sixth days of service), the knight receivesthree gold coins. On each of the next four days (the seventh,eighth, ninth, and tenth days of service), the knight receives fourgold coins. This pattern of payments will continue indefinitely:after receiving
N gold coins on each of N consecutive days, theknight will receive N+1 gold coins on each of the next N+1consecutive days, where N is any positiveinteger.Your program will determine the total number of gold coins paid tothe knight in any given number of days (starting from Day1).InputThe input contains at least one, but no more than21 lines. Each line of the input file (except the last one)contains data for one test case of the problem, consisting ofexactly one integer (in the range 1..10000), representing thenumber of days. The end of
the input is signaled by a linecontaining the number 0.OutputThere is exactly one line of output for each testcase. This line contains the number of days from the correspondingline of input, followed by one blank space and the total number ofgold coins paid to the knight in the given number of days, startingwith Day
1.Sample Input
10
6
7
11
15
16
100
10000
1000
21
22
0
Sample Output
10 30
6 14
7 18
11 35
15 55
16 61
100 945
10000 942820
1000 29820
21 91
22 98


~~水水的过~~~

AC代码:


#include<iostream>

#include<stdio.h>

#include<string.h>

#include<string>

#include<algorithm>

#include<stdlib.h>

#include<cmath>

using namespace std;

//-------------------------------------------

int main()

{

int n;

int s1,s2;

while(scanf("%d",&n),n)

  {

s1=s2=0;

for(int i=1;;i++)

         {

s1+=i*i;

s2+=i;

if(s2==n)  break;

else if(s2>n)  { s1-=(s2-n)*i;break;}

}

cout<<n<<" "<<s1<<"\n";

}

return 0;


}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: