您的位置:首页 > 其它

浙大2012上机 PAT 1032. Sharing (25)

2014-03-22 10:09 561 查看
To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.



Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total
number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, andNext is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:
67890

Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:
-1


代码如下:

#include<iostream>
#include<vector>
#include<cstring>
#include<cstdio>
using namespace std;
const int MAXN=100000;
int flag[MAXN];
int node[MAXN];
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("D:\\in.txt","r",stdin);
freopen("D:\\out.txt","w",stdout);
#endif
int ad1,ad2,N;
scanf("%d%d%d",&ad1,&ad2,&N);
int a(0),b(0);
memset(node,0,sizeof(node));
memset(flag,0,sizeof(flag));
char c;
while(N--)
{
scanf("%d %c %d",&a,&c,&b);
node[a]=b;
}
a=ad1;
while(a!=-1)
{
flag[a]=1;
a=node[a];
}
b=ad2;
//while(b!=-1&&!flag[b])
while(!flag[b]&&b!=-1)
{
//flag[b]=1;
b=node[b];
}
if(b!=-1)
printf("%05d\n",b);//格式问题呀!!!一定要注意!!!
else
printf("-1\n");
return 0;
}


下面是使用map的代码,最后一个case超时,待优化。

//采用map,最后一个case超时
#include <iostream>
#include <string>
#include <map>
using namespace std;

int main()
{
int n,i;
string start1,start2,start,ch,end;
map<string,string> d,dt;
cin>>start1>>start2>>n;
for(i = 0 ; i < n ; i++)
{
cin>>start>>ch>>end;
d[start] = end;
}

while(start1 != "-1")
{
dt[start1] = "y";
start1 = d[start1];
}
while(start2 != "-1")
{
if(dt[start2] == "y")
{
cout<<start2<<endl;
return 0;
}
start2 = d[start2];
}
cout<<"-1"<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: