您的位置:首页 > 其它

HDU 1196 Lowest Bit

2014-03-21 21:05 363 查看
Problem Description

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output

For each A in the input, output a line containing only its lowest bit.

Sample Input

26
88
0


Sample Output

2
8
#include<iostream>
using namespace std;
int n;
int l(int x)
{
return x&(-x);
}
int main()
{
while(scanf("%d",&n)!=EOF&&n)
{
printf("%d\n",l(n));
}
return 0;
}
就是求第一个不为0的数位,有多少0就是2的多少次方。
#include <iostream>
using namespace std;
int main()
{
int A,Ans;
while(cin>>A)
{
if(A==0)break;
Ans = 1;
while(A%2==0)
{
A /= 2;
Ans *= 2;
}
cout<<Ans<<endl;
}
return 0;
}
转的一个模拟
#include <stdio.h>
#include <string.h>
int set(int n)
{
char str[10000];
int k = 0;
while(n)
{
int r = n%2;
str[k++] = r+'0';
n/=2;
}
str[k] = '\0';
int i;
for(i = 0;i<k;i++)
{
if(str[i]=='1')
break;
}
return i;
}

int pow(int n)
{
int s = 1;
for(int i = 1;i<=n;i++)
s*=2;
return s;
}
int main()
{
int n,k;
while(~scanf("%d",&n),n)
{
k = set(n);
k = pow(k);
printf("%d\n",k);
}

return 0;
}





                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: