您的位置:首页 > 其它

POJ训练计划2632_Crashing Robots(模拟)

2014-03-21 15:39 309 查看
 Crashing Robots
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d
& %I64u

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor
space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are
processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 

A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 

The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 

Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 


 

Figure 1: The starting positions of the robots in the sample warehouse

Finally there are M lines, giving the instructions in sequential order. 

An instruction has the following format: 

< robot #> < action> < repeat> 

Where is one of 
L: turn left 90 degrees, 

R: turn right 90 degrees, or 

F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case: 
Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.) 

Robot i crashes into robot j, if robots i and j crash, and i is the moving robot. 

OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20


Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2


解题报告
模拟一题。。。
在每次向前走一步的时候判断是否有撞到其他机器人即可;还要注意的是break和continen的差别;
模拟题嘛,代码就是长,还好单步可以很清楚的调试。
#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;
struct node
{
int x,y;
char D[2];
} rob[200];
int mmap[200][200];
int main()
{
int n,m,a,b,i,j,t;
int R,T;
char A[2];
scanf("%d",&t);
while(t--)
{
int f=0;
memset(mmap,0,sizeof(mmap));
scanf("%d%d",&b,&a);
scanf("%d%d",&n,&m);
for(i=1; i<=n; i++)
{
scanf("%d%d%s",&rob[i].y,&rob[i].x,rob[i].D);
rob[i].x=a-rob[i].x+1;
mmap[rob[i].x][rob[i].y]=i;
}
while(m--)
{

scanf("%d%s%d",&R,A,&T);
if(f)continue;
mmap[rob[R].x][rob[R].y]=0;
if(rob[R].D[0]=='E')
{
if(A[0]=='F')
{
for(i=1; i<=T; i++)
{
if(rob[R].y+i<=b)
{
if(mmap[rob[R].x][rob[R].y+i]!=0)
{
f=1;
printf("Robot %d crashes into robot %d\n",R,mmap[rob[R].x][rob[R].y+i]);
break;
}
}
}
if(f==0)
{
rob[R].y+=T;
if(rob[R].y>b)
{
f=1;
printf("Robot %d crashes into the wall\n",R);
continue;
}
else mmap[rob[R].x][rob[R].y]=R;
}
}
else if(A[0]=='L')
{
int k=T%4;
switch(k)
{
case 0:
rob[R].D[0]='E';
break;
case 1:
rob[R].D[0]='N';
break;
case 2:
rob[R].D[0]='W';
break;
case 3:
rob[R].D[0]='S';
break;
}
}
else if(A[0]=='R')
{
int k=T%4;
switch(k)
{
case 0:
rob[R].D[0]='E';
break;
case 1:
rob[R].D[0]='S';
break;
case 2:
rob[R].D[0]='W';
break;
case 3:
rob[R].D[0]='N';
break;
}
}
}
else if(rob[R].D[0]=='W')
{
if(A[0]=='F')
{
for(i=1; i<=T; i++)
{
if(rob[R].y-i>=1)
{
if(mmap[rob[R].x][rob[R].y-i]!=0)
{
f=1;
printf("Robot %d crashes into robot %d\n",R,mmap[rob[R].x][rob[R].y-i]);
break;
}
}
}
if(f==0)
{
rob[R].y-=T;
if(rob[R].y<1)
{
f=1;
printf("Robot %d crashes into the wall\n",R);
continue;
}
else mmap[rob[R].x][rob[R].y]=R;
}
}
else if(A[0]=='R')
{
int k=T%4;
switch(k)
{
case 0:
rob[R].D[0]='W';
break;
case 1:
rob[R].D[0]='N';
break;
case 2:
rob[R].D[0]='E';
break;
case 3:
rob[R].D[0]='S';
break;
}
}
else if(A[0]=='L')
{
int k=T%4;
switch(k)
{
case 0:
rob[R].D[0]='W';
break;
case 1:
rob[R].D[0]='S';
break;
case 2:
rob[R].D[0]='E';
break;
case 3:
rob[R].D[0]='N';
break;
}
}
}
else if(rob[R].D[0]=='N')
{
if(A[0]=='R')
{
int k=T%4;
switch(k)
{
case 0:
rob[R].D[0]='N';
break;
case 1:
rob[R].D[0]='E';
break;
case 2:
rob[R].D[0]='S';
break;
case 3:
rob[R].D[0]='W';
break;
}
}
else if(A[0]=='F')
{
for(i=1; i<=T; i++)
{
if(rob[R].x-i>=1)
{
if(mmap[rob[R].x-i][rob[R].y]!=0)
{
f=1;
printf("Robot %d crashes into robot %d\n",R,mmap[rob[R].x-i][rob[R].y]);
break;
}
}
}
if(f==0)
{
rob[R].x-=T;
if(rob[R].x<1)
{
f=1;
printf("Robot %d crashes into the wall\n",R);
continue;
}
else mmap[rob[R].x][rob[R].y]=R;
}
}
else if(A[0]=='L')
{
int k=T%4;
switch(k)
{
case 0:
rob[R].D[0]='N';
break;
case 1:
rob[R].D[0]='W';
break;
case 2:
rob[R].D[0]='S';
break;
case 3:
rob[R].D[0]='E';
break;
}
}
}
else if(rob[R].D[0]=='S')
{
if(A[0]=='L')
{
int k=T%4;
switch(k)
{
case 0:
rob[R].D[0]='S';
break;
case 1:
rob[R].D[0]='E';
break;
case 2:
rob[R].D[0]='N';
break;
case 3:
rob[R].D[0]='W';
break;
}
}
else if(A[0]=='F')
{
for(i=1; i<=T; i++)
{
if(rob[R].x+i<=a)
{
if(mmap[rob[R].x+i][rob[R].y]!=0)
{
f=1;
printf("Robot %d crashes into robot %d\n",R,mmap[rob[R].x+i][rob[R].y]);
break;
}
}
}
if(f==0)
{
rob[R].x+=T;
if(rob[R].x>a)
{
f=1;
printf("Robot %d crashes into the wall\n",R);
continue;
}
else mmap[rob[R].x][rob[R].y]=R;
}
}
else if(A[0]=='R')
{
int k=T%4;
switch(k)
{
case 0:
rob[R].D[0]='S';
break;
case 1:
rob[R].D[0]='W';
break;
case 2:
rob[R].D[0]='N';
break;
case 3:
rob[R].D[0]='E';
break;
}
}
}
}
if(f==0)printf("OK\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: